Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 23904 | Accepted: 12927 |
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13
Source
题意:给一个图,'@'是起点,'.'可以通过,'#'不可以通过。问从起点出发最多可以到达图中的多少个点。
解析:从起点深搜即可,每次dfs的时候,都把当前的起点改为’@‘,每次向四个方向搜索的时候,只有不出边界且当前点为’.'的时候才继续深搜。只需要记录多少次dfs即为答案。
AC代码:
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <cmath>
#include <cstdlib>
#include <ctime>
#include <stack>
using namespace std;
#define INF 0x7fffffff
#define LL long long
#define MID(a, b) a+(b-a)/2
const int maxn = 1000 + 10;
int d[4][2] = {0, 1, 0, -1, 1, 0, -1, 0};
int m, n, ans;
char s[22][22];
void dfs(int x, int y){
s[x][y] = '@';
ans ++;
for(int i=0; i<4; i++){
int dx = x + d[i][0], dy = y + d[i][1];
if(dx < n && dx >=0 && dy < m && dy >=0 && s[dx][dy] == '.') //开始用的条件是s[dx][dy] != '#',程序老是死掉!!!
dfs(dx, dy);
}
}
int main(){
#ifdef sxk
freopen("in.txt", "r", stdin);
#endif // sxk
int sx = 0, sy = 0;
while(scanf("%d%d", &m, &n)!=EOF && !(!n && !m)){
ans = 0;
for(int i=0; i<n; i++)
for(int j=0; j<m; j++){
cin >> s[i][j];
if(s[i][j] == '@'){ //记录起点坐标
sx = i;
sy = j;
}
}
dfs(sx, sy);
printf("%d\n", ans);
}
return 0;
}