2013 ACM-ICPC吉林通化全国邀请赛 && HDU 4499 Cannon (搜索)

31 篇文章 0 订阅

Cannon
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 21 Accepted Submission(s): 14

Problem Description
In Chinese Chess, there is one kind of powerful chessmen called Cannon. It can move horizontally or vertically along the chess grid. At each move, it can either simply move to another empty cell in the same line without any other chessman along the route or perform an eat action. The eat action, however, is the main concern in this problem.
An eat action, for example, Cannon A eating chessman B, requires two conditions:
1、A and B is in either the same row or the same column in the chess grid.
2、There is exactly one chessman between A and B.
Here comes the problem.
Given an N x M chess grid, with some existing chessmen on it, you need put maximum cannon pieces into the grid, satisfying that any two cannons are not able to eat each other. It is worth nothing that we only account the cannon pieces you put in the grid, and no two pieces shares the same cell.

Input
There are multiple test cases.
In each test case, there are three positive integers N, M and Q (1<= N, M<=5, 0<=Q <= N x M) in the first line, indicating the row number, column number of the grid, and the number of the existing chessmen.
In the second line, there are Q pairs of integers. Each pair of integers X, Y indicates the row index and the column index of the piece. Row indexes are numbered from 0 to N-1, and column indexes are numbered from 0 to M-1. It guarantees no pieces share the same cell.

Output
There is only one line for each test case, containing the maximum number of cannons.

Sample Input
4 4 2 

1 1 1 2 

5 5 8 

0 0 1 0 1 1 2 0 2 3 3 1 3 2 4 0

Sample Output
8 9

Source
2013 ACM-ICPC吉林通化全国邀请赛——题目重现


Recommend
liuyiding




解析:从上到下,从左到右直接搜索炮可以存在的位置即可,注意剪枝(炮冲突的情况)




AC代码:

#include <bits/stdc++.h>
using namespace std;

int n, m, q;
int g[10][10];
int ans;

void dfs(int x, int y, int cnt){
    if(x >= n){    //搜索结束
        ans = max(ans, cnt);
        return ;
    }
    if(y >= m){    //一行结束
        dfs(x+1, 0, cnt);    //从下一行开始搜
        return ;
    }
    if(g[x][y] == 1){    //当前位置已有其他棋子
        dfs(x, y+1, cnt);
        return ;
    }
    dfs(x, y+1, cnt);

    //检查当前y列有无冲突的炮存在
    bool tg = false;
    int t;
    for(t=x-1; t>=0; t--) if(g[t][y]) break;
    for(int i=t-1; i>=0; i--) if(g[i][y]){
        if(g[i][y] == 2) tg = true;
        break;
    }
    if(tg) return ;

    //检查当前x行有无冲突的炮存在
    for(t=y-1; t>=0; t--) if(g[x][t]) break;
    for(int i=t-1; i>=0; i--) if(g[x][i]){
        if(g[x][i] == 2) tg = true;
        break;
    }
    if(tg) return ;

    g[x][y] = 2;
    dfs(x, y+1, cnt+1);
    g[x][y] = 0;
}

int main(){
    #ifdef sxk
        freopen("in.txt", "r", stdin);
    #endif // sxk
    int x, y;
    while(scanf("%d%d%d", &n, &m, &q) == 3){
        memset(g, 0, sizeof(g));
        for(int i=0; i<q; i++){
            scanf("%d%d", &x, &y);
            g[x][y] = 1;
        }
        ans = 0;
        dfs(0, 0, 0);
        printf("%d\n", ans);
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值