1489 求二叉树的先序遍历

求二叉树的先序遍历

Time Limit: 1000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历

输入

 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 

输出

 输出二叉树的先序遍历序列

示例输入

2
dbgeafc
dgebfca
lnixu
linux

示例输出

abdegcf
xnliu





#include <stdio.h>
#include <stdlib.h>
#include <string.h>
struct node
{
    char data ;
    struct node *l,*r;
};
struct node *build (char *a,char *b,int n)
{
    struct node *p;
    if (n<=0)
        return NULL;
    int k=0;
    p=(struct node *)malloc(sizeof (struct node ));
    p->data=*(b+n-1);//b为后序,所以b的最后一个字符为整个二叉树的根结点
    printf ("%c",p->data);//求的是先序遍历,根->左->右,so 先输出结点
    for (k=0; k<n; k++)
    {
        if (a[k]==*(b+n-1))//在中序中找与结点相同的元素
            break;
    }
    p->l=build(a,b,k);//k表示在此结点的左子树中元素个数
    p->r=build(a+k+1,b+k,n-k-1);
//a+k+1表示a数组中去掉1个根结点和k个属于左子树的元素所剩下的元素形成的新的数组a,也就是属于右子树的元素
//b+k表示b数组中去掉k个属于左子树的元素所剩下的元素形成的新的数组b
//n-k-1表示在此结点的右子树中的元素个数
    return p;
}

int main ()
{
    int t,len;
    char a[100],b[100];
    struct node *tree;
    while (~scanf ("%d",&t))
    {
        while (t--)
        {
            scanf ("%s%s",a,b);//a表示中序,b表示后序
            len =strlen (b);
            tree=build(a,b,len);//生成二叉树
            printf ("\n");
        }
    }
    return 0;
}






#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
using namespace std;


char a[1000],b[1000];

struct node
{
    char data;
    struct node *l,*r;
};

struct node *build (char *a,char *b,int n)
{
    struct node *t;
    if ( n <= 0)
        return NULL;
    char x = b[n - 1];
    t = (struct node *)malloc(sizeof (struct node));
    t -> data = x;
    int i;
    for (i = 0; i < n;i++)
    {
        if ( a[i] == x )
            break;
    }
    t -> l = build (a,b,i);
    t -> r = build (a + 1 + i,b + i,n - i - 1);
    return t;
}

void first (struct node *t)
{
    if (t == NULL )
        return ;
    printf ("%c",t -> data);
    first (t -> l);
    first (t -> r);
}

int main ()
{
    int t;
    struct node *tree;
    while (~scanf ("%d",&t))
    {
        while (t--)
        {
            scanf ("%s%s",a,b);
            int len = strlen (a);
            tree = build (a,b,len);
            first (tree);
            printf ("\n");
        }
    }
    return 0;
}


  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值