POJ 2586 Y2K Accounting Bug

Y2K Accounting Bug
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9748 Accepted: 4860

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit.  MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year.  ACM knows that each of these 8 postings reported a deficit but they do not know how much.  The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit


好坑的大水题。。。光读题就开了  有道  百度  Google  三个翻译。。。结果没看出啥意思来。。。

题目大意是一个公司在12个月中,或固定盈余s,或固定亏损d.但记不得哪些月盈余,哪些月亏损,只能记得连续5个月的代数和总是亏损,问全年是否可能盈利?若可能,输出可能最大盈利金额,否则输出“Deficit".

每连续5个月中,在保证这5个月经营之和为亏损的情况下,亏损的月数肯定应尽量往后选,盈利的月数应尽量往前选。。。


保证“连续5个月必亏损”可分为以下几种情况:


1.SSSSDSSSSDSS        4s<d 

2.
SSSDDSSSDDSS      3s<2d

3.
SSDDDSSDDDSS      2s<3d

4.
SDDDDSDDDDSD     s<4d

5
.DDDDDDDDDDDD    5d 


#include <iostream>
#include <stdio.h>

using namespace std;

int main()
{
    int s,d,sum;
    while (~scanf ("%d%d",&s,&d))
    {
        int flag=0;
        sum=0;
        if (s*4 < d)
        {
            sum = 10*s - 2*d;
            if (sum > 0)
                printf ("%d\n",sum);
            else flag=1;
        }
        else if (s*3 < 2*d)
        {
            sum = 8*s - 4*d;
            if (sum > 0)
                printf ("%d\n",sum);
            else flag=1;
        }
        else if (s*2 <3*d)
        {
            sum = 6*s - 6*d;
            if (sum > 0 )
                printf ("%d\n",sum);
            else flag=1;
        }
        else if (s < 4*d)
        {
            sum = 3*s - 9*d;
            if (sum > 0)
                printf ("%d\n",sum);
            else flag=1;
        }
        else flag=1;
        if (flag==1)
            printf ("Deficit\n");
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值