POJ 3259 Wormholes (Bellman_Ford)

Wormholes

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  F F  farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  N M , and  W  
Lines 2.. M +1 of each farm: Three space-separated numbers ( S E T ) that describe, respectively: a bidirectional (双向) path between  S  and  E  that requires  T  seconds to traverse. Two fields might be connected by more than one path. 
Lines  M +2.. M + W +1 of each farm: Three space-separated numbers ( S E T ) that describe, respectively: A one way path from  S  to  E  that also moves the traveler back  T  seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.



POJ的题意怎么老是这么这么晦涩难懂。。。无语了都,本来英语就不咋的。。。

先说下题意吧:利用虫洞的时光旅行,如果农夫能看到过去的自己(也就是有负环)就输出YES,反之输出NO。显然要用到Bellman-Ford算法判断负环。

需要注意的是Input输入说明的部分。。很难看懂;

F:表示有多少组测试数据;

N、M、W:N个农场,M条路,W个虫洞;

S、E、T:1.S-->E所需时间(双向、S->E.E->S、正权)

  2.E-->S所需时间(单向、E->S、负权) 建图的时注意一下。

至于Bellman-Ford就不多说了。。。上代码。





#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
using namespace std;

const int inf=99999999;
int dis[inf],m,n,w,a,b,c,T;
struct node
{
    int s,e,t;
} p[inf];

int Bellman (int s)
{
    for (int i=0; i<=n; i++)
    {
        dis[i]=inf;
    }
    int flag;
    for (int i=0; i<n; i++)
    {
        flag=0;
        for (int j=0; j<s; j++)
        {
            if (dis[p[j].e] > dis[p[j].s]+p[j].t)
            {
                flag=1;
               dis[p[j].e]= dis[p[j].s]+p[j].t;
            }
        }
        if (flag==0)
            break;
    }
    for (int j=0;j<s;j++)
    {
        if (dis[p[j].e] > dis[p[j].s]+p[j].t)
        {
            return 1;
        }
    }
    return 0;
}

int main()
{
    scanf ("%d",&T);
    while (T--)
    {
       int s=0;
        scanf ("%d%d%d",&n,&m,&w);
        for (int i=0; i<m; i++)
        {
            scanf ("%d%d%d",&a,&b,&c);
            //双向建图
            p[s].s=a;p[s].e=b;p[s++].t=c;
            p[s].s=b;p[s].e=a;p[s++].t=c;
        }
        for (int i=0; i<w; i++)
        {
            scanf ("%d%d%d",&a,&b,&c);
            //单向建图 && b->a
            p[s].s=b;p[s].e=a;p[s++].t=-c;
        }

        if (Bellman(s)==0)
            printf ("NO\n");
        else printf ("YES\n");
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值