poj 3259 Wormholes

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 43824 Accepted: 16091

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

这一题的大意是
/*

题目大意:农场有N个点,M条双向边,每条边信息为——从S到E花费的时间为T,同理从T到S花费的时间

也为T。现在农场出现了W个虫洞,每个虫洞意味着:从S到E花费的时间为-T(时间倒流,但是虫洞是单向边)。

问:从N个点中的某点开始走,能否使时间倒流。

*/
说白了就是找有没有负环的问题

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <iostream>
#define MAX 0x3f3f3f3f
using namespace std;
struct node
{
    int x,y,z;
} a[10002];
int dis[10002];
int main()
{
    int t,n,m,i,j;
    int k;
    scanf("%d",&t);
    while(t--)
    {
        int ok = 0;
        scanf("%d %d %d",&n,&m,&k);
        for(i = 0; i < 2*m; i++)
        {
            scanf("%d %d %d",&a[i].x,&a[i].y,&a[i].z);
            a[++i].x = a[i-1].y;
            a[i].y = a[i-1].x;
            a[i].z = a[i-1].z;
        }
        int h;
        for(i; i < 2*m+k; i++)                    //用结构体a[]把所有的数据存起来一共有2*m+k个
        {
            scanf("%d %d %d",&a[i].x,&a[i].y,&h);
            a[i].z = -h;
        }
        memset(dis,0,sizeof(dis));               //查找负环问题的关键
        for(i = 0; i < n; i++)                     //当松弛到n-1次时如果无负环第n次就不会被改变,当有负环时n以及什么时候都会被改变
        {
            for(j = 0; j < 2*m+k; j++)
            {
                if(dis[a[j].y] > dis[a[j].x] +a[j].z)
                {
                    dis[a[j].y] = dis[a[j].x]+a[j].z;
                    if(i==n-1)                       //当第n次被改变时
                    {
                        ok=1;
                    }
                }
            }
            if(ok == 1)
                break;
        }
        if( ok )
            printf("YES\n");
        else
            printf("NO\n");
    }
}


代码菜鸟,如有错误,请多包涵!!!
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值