Rightmost Digit
Problem Description
Given a positive integer N, you should output the most right digit of N^N.
Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
Output
For each test case, you should output the rightmost digit of N^N.
Sample Input
2 3 4
Sample Output
7 6HintIn the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
白书上的函数 是这么写的:
int pow_mid (int a,int n,int m)
{
if (n == 0) return 1;
int x = pow_mid (a,n/2,m);
long long ans = (long long ) x * x % m;
if (n % 2 == 1)
ans = ans * a % m;
return (int )ans;
}
采用的是分治的思想(跟二分查找很类似,每次规模减小近一半),每次幂数/2,假如a^29 = a^14^2 *a ,a^14=a^7^2, a^7=a^3^2*a, a^3=a^2*a, ..总共进行7次乘法。因此时间复杂度为O(logN),比O(N)好多了。。。
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <math.h>
using namespace std;
int pow_mid (int a,int n,int m)
{
if (n == 0)
return 1;
int x = pow_mid (a,n/2,m);
long long ans = (long long ) x * x % m;
if (n % 2 == 1)
ans = ans * a % m;
return (int )ans;
}
int main ()
{
int a,n,m;
while (~scanf ("%d",&n))
{
while ( n-- )
{
scanf ("%d",&a);
int s = pow_mid (a,a,10);
printf ("%d\n",s);
}
}
return 0;
}