数据结构实验之链表五:单链表的拆分
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
输入N个整数顺序建立一个单链表,将该单链表拆分成两个子链表,第一个子链表存放了所有的偶数,第二个子链表存放了所有的奇数。两个子链表中数据的相对次序与原链表一致。
输入
第一行输入整数N;;
第二行依次输入N个整数。
第二行依次输入N个整数。
输出
第一行分别输出偶数链表与奇数链表的元素个数;
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。
第二行依次输出偶数子链表的所有数据;
第三行依次输出奇数子链表的所有数据。
示例输入
10 1 3 22 8 15 999 9 44 6 1001
示例输出
4 6 22 8 44 6 1 3 15 999 9 1001
#include<stdio.h>
#include<stdlib.h>
struct node
{
int data;
struct node *next;
};
int main()
{
int m,s=0,i;
struct node *head,*p,*tail,*head1,*tail1;
head=(struct node*)malloc(sizeof(struct node));
head1=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
tail=head;
head1->next=NULL;
tail1=head1;
scanf("%d",&m);
for(i=0;i<m;i++)
{
p=(struct node*)malloc(sizeof(struct node));
scanf("%d",&p->data);
if(p->data%2==0)
{
p->next=NULL;
tail->next=p;
tail=p;
s++;
}
else
{
p->next=NULL;
tail1->next=p;
tail1=p;
}
}
printf("%d %d\n",s,m-s);
for(p=head->next;p;p=p->next)
{
if(p->next)printf("%d ",p->data);
else printf("%d\n",p->data);
}
for(p=head1->next;p;p=p->next)
{
if(p->next)printf("%d ",p->data);
else printf("%d\n",p->data);
}
return 0;
}