Number Sequence 当f[i]==f[2]&&f[i-1]==f[1],周期=i-2


Number Sequence
Time Limit: 1000MS Memory limit: 65536K

题目描述

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

输入

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

输出

For each test case, print the value of f(n) on a single line.

示例输入

1 1 3
1 2 10
0 0 0

示例输出

2
5
 
 
#include<stdio.h>
int f[100000];
int main()
{
 int i,a,b,n;
 f[1]=1;f[2]=1;
 while(scanf("%d%d%d",&a,&b,&n)!=EOF&&a||b||n)
 {
  for(i=3;i<10000;i++)
  {
   f[i]=(a*f[i-1]+b*f[i-2])%7;
   if(f[i]==1&&f[i-1]==1)
    break;
  }
  n=n%(i-2);
  printf("%d\n",f[n]);
 }
}
 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值