*十点半
Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^
题目描述
十点半是一个纸牌游戏,或者说数字游戏。这里简化一下,规则是每个人摸两张牌,然后只通过加减运算,如果能够得到十点半的话就算赢,否则就输。扑克从2到K分别代表2~13点,A代表半点,然后王或老头或司令随便你怎么叫,不分大小,都代表半点。
输入
输入有多组数据。第一行一个正整数T代表数据的组数。接下来N行,每行两张牌。其中11到13的牌是J,Q,K,王是S。
输出
输出也要N行,每行的格式是如果赢了Case P: WIN,输了Case P: LOSE。其中P代表是第几组数据。
示例输入
4 10 A A J 10 S 2 8
示例输出
Case 1: WIN Case 2: WIN Case 3: WIN Case 4: LOSE
#include <stdio.h>
#include <string.h>
void main()
{
char a[2],b[2];
int n,q=1;
scanf("%d%*c",&n);
while(n--){
scanf("%s%s",a,b);
if((a[0]=='A'||a[0]=='S')&&(strcmp(b,"10")==0||b[0]=='J')||(b[0]=='A'||b[0]=='S')&&(strcmp(a,"10")==0||a[0]=='J'))printf("Case %d: WIN\n",q++);
else printf("Case %d: LOSE\n",q++);
}
}