Rightmost Digit(简单数论_幂取模)

Rightmost DigitCrawling in process...Crawling failedTime Limit:1000MS    Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Given a positive integer N, you should output the most right digit of N^N.
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output

For each test case, you should output the rightmost digit of N^N.
 

Sample Input

     
     
2 3 4
 

Sample Output

     
     
7 6

Hint

In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 
   
 
   
 
   
 
   
题意:就是求n*n的个位数
 
   
思路:这是典型的幂取模的应用;
对于a^n%m来说  一般的做法是
int pow(int a,int n,int m)
{
    int ans=1;
    for(int i=0;i<n;i++)
    ans=(int)((long long)ans*n%m);
}
时间复杂度为O(n),当n很大的时候速度就很不理想。下面这种算法就能很大的提高速度:
利用分治法
int pow_mod(int a,int n,int m)
{
    int x=pow_mod(a,n/2,m);
    long long ans=(long long)x*x%m;
    if(n%2==1)
        ans=ans*a%m;
    return (int)ans;
}
例如a^29=(a^14)^2*a----->a^14=(a^7)^2----->a^7=(a^3)^2*a----->a^3=a^2*a;
一共只做了七次乘法,近似二分查找,每次规模减少近一半,时间复杂度为O(log n);
 
   
 
   
 
   
 
   
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <map>
#include <string>
#include <algorithm>
#include <iostream>
#include <queue>
using namespace std;

int pow_mod(int a,int n,int m)
{
    int ans= 1;
    while (n > 0)
    {
        if (n%2==1)
        {
            ans=ans*a%m;
        }
        a*=a;
        a%=m;
        n/=2;
    }
    return ans;
}

int main()
{
    int T;
    int n,t;
    scanf("%d", &T);
    while(T--)
    {
        scanf("%d", &n);
        t=pow_mod(n%10,n,10);
        printf("%d\n", t);
    }
    return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值