HDU1068-Girls and Boys(二分图_最大独立集)

Description

the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Input

Output

Sample Input

    
    
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output

    
    
5 2
没有所谓的集合A和集合B了,所有人都在相互喜欢.就是说0 喜欢 4 5 6,4 5 6也喜欢 0.也就是说这里的数字是不分男女的(所以在dfs的结果出来以后要除以2,因为每个人都用了两次)。
思路:依旧是匈牙利算法,独立集指的是两两之间没有边的顶点的集合。
二分图的最大独立集=节点数-最大匹配数。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int G[1100][1100];
int vis[1100];
int link[1100];
int n;
int dfs(int x)
{
    int i;
    for(i=0;i<n;i++)
    {
       if(G[x][i]==1&&vis[i]==0)
       {
           vis[i]=1;
           if(link[i]==0||dfs(link[i]))
           {
              link[i]=x;
              return 1;
           }
       }
    }
    return 0;
}
int main()
{
    int i,j;
    int a,b,c;
    int sum=0;
    while(~scanf("%d",&n))
    {
        memset(G,0,sizeof(G));
        memset(link,0,sizeof(link));
        for(i=0;i<n;i++)
        {
           scanf("%d: (%d)",&a,&b);
           while(b--)
           {
              scanf("%d",&c);
              G[a][c]=1;
           }
        }
        sum=0;
        for(i=0;i<n;i++)
        {
           memset(vis,0,sizeof(vis));
           if(dfs(i))
            sum++;
        }
        printf("%d\n",n-sum/2);
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值