Hangover(水题)

20 篇文章 1 订阅

Hangover


Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 102372 Accepted: 49833

Description


How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.

Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.

Sample Input

1.00
3.71
0.04
5.19
0.00

Sample Output

3 card(s)
61 card(s)
1 card(s)
273 card(s)
题目大意:你可以把一叠卡片放的离桌子多远?如果有一张卡片,那么可达到的最远距离是卡片唱的的一半(假设卡片必须与桌子的边缘垂直),是用两张卡片,是上面一张能放到的最远距离超过下面长度的一半,而下面一张超过桌子的是卡片长度的1/3,所以能达到的最远距离是:1/2+1/3=5/6。一半来说,n张卡片能达到的最远距离是1/2+1/3+1/4+....+1/(n+1),也就是最顶上的卡片超出第二张的1/2,第二张超出第三张的1/3,第三张超出第四张的1/4,等等,输入一行数字0.00时表示输入结束,每个测试例一行,是一个浮点数c(0.01<=c<=5.20),c刚好是3位数字。对每个测试例,输出达到距离c所需要的最少卡片的数量。注意输出格式!
 
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
int main()
{
    double n;
    double sum;
    int i;
    while(~scanf("%lf",&n),n)
    {
        sum=0;
        for(i=1; sum<n; i++)
        {
            sum+=1.0/(i+1);
        }
        printf("%d card(s)\n",i-1);
    }

    return 0;
}

 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值