UVA 465- Overflow(借助atof函数将字符串改为double型)

Overflow
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu

Description

Download as PDF


 Overflow 

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal'' signed integer (type integer if you are working Pascal, type int if you are working in C).

Input

An unspecified number of lines. Each line will contain an integer, one of the two operators + or *, and another integer.

Output

For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ``first number too big'', ``second number too big'', ``result too big''.

Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big

这个是问哪个值超了int类型 int类型的正整数范围为2^31


#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#define inf 2147483647
char a[1010];
char b[1010];
int main()
{
    char str;
    double n,m;
    while(~scanf("%s %c %s",a,&str,b))
    {
        n=atof(a);
        m=atof(b);
        printf("%s %c %s\n",a,str,b);
        if(n>inf)
        printf("first number too big\n");
        if(m>inf)
        printf("second number too big\n");
        if(str=='+'&&n+m>inf)
        printf("result too big\n");
        if(str=='*'&&n*m>inf)
        printf("result too big\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值