SDUT 2605-A^X mod P(大幂分解求和)

A^X mod P

Time Limit: 5000ms   Memory limit: 65536K  有疑问?点这里^_^

题目描述

It's easy for ACMer to calculate A^X mod P. Now given seven integers n, A, K, a, b, m, P, and a function f(x) which defined as following.

f(x) = K, x = 1

f(x) = (a*f(x-1) + b)%m , x > 1


Now, Your task is to calculate

( A^(f(1)) + A^(f(2)) + A^(f(3)) + ...... + A^(f(n)) ) modular P. 

输入

 In the first line there is an integer T (1 < T <= 40), which indicates the number of test cases, and then T test cases follow. A test case contains seven integers n, A, K, a, b, m, P in one line.

1 <= n <= 10^6

0 <= A, K, a, b <= 10^9

1 <= m, P <= 10^9

输出

 For each case, the output format is “Case #c: ans”. 

c is the case number start from 1.

ans is the answer of this problem.

示例输入

23 2 1 1 1 100 1003 15 123 2 3 1000 107

示例输出

Case #1: 14Case #2: 63

提示

 

来源

2013年山东省第四届ACM大学生程序设计竞赛

题意:求A^X mod P的和。

PS:妥妥的给跪了,用快速幂肯定不行,超时,然后用了一下快速幂+快速乘法还是超时,一直优化优化也优化好,只好去看了下题解,真心给跪了。

思路:这个用到了分解的方法,将A^f中的 f分解为  i * k + j的形式 。保存在数组中,用的时候直接找就好了。

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double pi= acos(-1.0);
const int maxn=33333;
LL  X[maxn+10],Y[maxn+10];
LL n,A,K,a,b,m,P;
void Init()
{
    int i;
    X[0]=1;
    for(i=1;i<=maxn;i++){
        X[i]=(X[i-1]*A)%P;
    }
    LL tmp=X[maxn];
    Y[0]=1;
    for(i=1;i<=maxn;i++){
        Y[i]=(Y[i-1]*tmp)%P;
    }
}
void Solve(int icase)
{
    int i;
    LL fx=K;
    LL res=0;
    for(i=1;i<=n;i++){
        res=(res+(Y[fx/maxn]*X[fx%maxn])%P)%P;
        fx=(a*fx+b)%m;
    }
   printf("Case #%d: %lld\n",icase,res);
}

int main()
{
    int T,icase;
    scanf("%d",&T);
    for(icase=1;icase<=T;icase++){
        scanf("%lld %lld %lld %lld %lld %lld %lld",&n,&A,&K,&a,&b,&m,&P);
        Init();
        Solve(icase);
    }
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值