POJ 3252- Round Numbers(求区间中二进制数中0个数大于1的数的总数)

51 篇文章 0 订阅
17 篇文章 0 订阅

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 10008 Accepted: 3628

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

题意:输入两个十进制正整数a和b,求闭区间[a ,b]内有多少个Round number。所谓的Round Number就是把一个十进制数转换为一个无符号二进制数,若该二进制数中0的个数大于等于1的个数,则它就是一个Round Number。

思路:

要知道闭区间[a ,b]内有多少个Round number,只需要分别求出
闭区间[0 ,a]内有T个RN,闭区间[0 ,b+1]内有S个RN
再用S – T就是闭区间[a ,b]内的RN数了
至于为什么是b+1,因为对于闭区间[0 ,k],我下面要说的算法求出的是比k小的RN数,就是说不管k是不是RN,都没有被计算在内,所以若要把闭区间[a ,b]的边界a和b都计算在内,就要用上述的处理方法。

详细解答:点击打开链接

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <sstream>
#include <algorithm>
#include <set>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long LL;
const int inf=0x3f3f3f3f;
const double eps=1e-10;
const double pi= acos(-1.0);
int c[35][35]= {0};
int two[35];
int len;
void C() {//从n件物品中取m件有多少种取法
  int i,j;
  c[0][0]=1;
  for(i=1;i<36;i++)
    for(j=0;j<=i;j++)
    if(!j)
    c[i][j]=c[i-1][j];
  else
    c[i][j]=c[i-1][j]+c[i-1][j-1];
}
void Ten_to_two(int x)//逆序存储二进制数
{
    len=0;
    while(x) {
        two[len++]=x%2;
        x=x/2;
    }
}
int RN(int n) {//求RN
    int i,j;
    int sum=0;
    Ten_to_two(n);
    //求二进制长度小于len的所有二进制数中RN的个数
    for(i=1; i<len-1; i++)//i+1(i+1<len)位数的二进制位数,第一位必为1,故不计入
        for(j=i/2+1; j<=i; j++)//j为其中0的位数
            sum+=c[i][j];
    int zero=0;//从高位向低位搜索中0的位的个数
    //求二进制长度等于len的所有二进制数中RN的个数
    for(i=len-2;i>=0;i--)
        if(two[i])//当前位为1
        for(j=(len+1)/2-(zero+1);j<=i;j++)
        sum+=c[i][j];
        else
        zero++;//zero记录在搜索过程中,已发现的0的个数
    return sum;
}

int main()
{
    int a,b;
    C();
    while(~scanf("%d %d",&a,&b)){
        printf("%d\n",RN(b+1)-RN(a));//此处亦有讲究,由于我们的round()所得为小于n的RN的个数,所b+1
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Rocky0429

一块也是爱

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值