Round Numbers(数位dp+dfs+记忆化模板)

Round Numbers
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 14777 Accepted: 5931

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins,
otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively  Start and  Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range  Start.. Finish

Sample Input

2 12

Sample Output

6

Source

[Submit]   [Go Back]   [Status]   [Discuss]



思路:

dp[i][j][k]其中i代表i位,j代表0的个数与1的个数的差,为了让其大于0,所以此处取j初始值为40,k取0或1代表前面出没出现过1。dfs(i,j,has,limit) 分别代表有i位,j代表0个数减去1个数值,has代表是否出现过1,因为因为数字不记录前导0,limit表示十分取值受限制

代码:

#include<iostream>
#include<cstring>
#include<vector>
#define LL long long 
using namespace std;

int dp[50][80][2];
vector<int>v;

int dfs(int pos,int s,int has,bool limit){
	if(pos==0){  //符合条件
		return s>=40&&has;
	}
	
	if(!limit&&dp[pos][s][has]!=-1){
		return dp[pos][s][has];
	}
	
	int i;
	int num=limit?v[pos-1]:1;  //注意此处应是1.
	int ans=0;
	for(i=0;i<=num;i++){
		if(has){
			if(i==0){  //前面存再1现在是0的情况
				ans+=dfs(pos-1,s+1,1,limit&&i==num);
			}
			else{  //存在1现在是1的情况
				ans+=dfs(pos-1,s-1,1,limit&&i==num);
			}
		}
		else{   //前面不存在1
			if(i==1){  //现在是1,
				ans+=dfs(pos-1,s-1,1,limit&&i==num);
			}
			else{  //仍然是0,不计数
				ans+=dfs(pos-1,s,has,limit&&i==num);
			}
		}
		
	}
	if(!limit){
		dp[pos][s][has]=ans;
	}
	return ans;
}

int solve(int x){
	v.clear();
	while(x>0){
		v.push_back(x%2);
		x/=2;
	}
	return dfs(v.size(),40,0,true);
}

int main(){
	int x,y;
	memset(dp,-1,sizeof(dp));
	while(cin>>x>>y){
		cout<<solve(y)-solve(x-1)<<endl;
	}
	return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值