HDU 1151 Air Raid【最小路径覆盖】


Air Raid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3866    Accepted Submission(s): 2556



Problem Description
Consider a town where all the streets are one-way and each street leads from one intersection to another. It is also known that starting from an intersection and walking through town's streets you can never reach the same intersection i.e. the town's streets form no cycles.

With these assumptions your task is to write a program that finds the minimum number of paratroopers that can descend on the town and visit all the intersections of this town in such a way that more than one paratrooper visits no intersection. Each paratrooper lands at an intersection and can visit other intersections following the town streets. There are no restrictions about the starting intersection for each paratrooper.
 

Input
Your program should read sets of data. The first line of the input file contains the number of the data sets. Each data set specifies the structure of a town and has the format:

no_of_intersections
no_of_streets
S1 E1
S2 E2
......
Sno_of_streets Eno_of_streets

The first line of each data set contains a positive integer no_of_intersections (greater than 0 and less or equal to 120), which is the number of intersections in the town. The second line contains a positive integer no_of_streets, which is the number of streets in the town. The next no_of_streets lines, one for each street in the town, are randomly ordered and represent the town's streets. The line corresponding to street k (k <= no_of_streets) consists of two positive integers, separated by one blank: Sk (1 <= Sk <= no_of_intersections) - the number of the intersection that is the start of the street, and Ek (1 <= Ek <= no_of_intersections) - the number of the intersection that is the end of the street. Intersections are represented by integers from 1 to no_of_intersections.

There are no blank lines between consecutive sets of data. Input data are correct.
 

Output
The result of the program is on standard output. For each input data set the program prints on a single line, starting from the beginning of the line, one integer: the minimum number of paratroopers required to visit all the intersections in the town.
 

Sample Input
  
  
2 4 3 3 4 1 3 2 3 3 3 1 3 1 2 2 3
 

Sample Output
  
  
2 1
 

Source


题目链接。


题目大意:
有一个城镇,它的所有街道都是单行道,且每条街与两个路口相连。同时保证街道不会形成回路。
求用最少的伞兵,去访问所有路口。伞兵可以访问任意路口,且最初位置也不受限。


解题思路:
求有向无环图DAG的最小路径覆盖。
将路口分为最初路口(所有)和到达路口(虚拟)。
最初路口也就是所有的路口。
到达路口设为虚设的路口。
将连通的两个路口相连,求最大匹配数(已有其他路口可达)。
最终可求得 伞兵数 = 路口数 - 最大匹配数。


#include <cstdio>
#include <cstring>
const int maxn = 150;
bool road[maxn][maxn],vis[maxn];
int ins[maxn];	//路口标记
int n,m;		//n表示路口数,m表示街道数 
void init()
{
	int i,si,ei;
	memset(road,0,sizeof(road));
	memset(ins,0,sizeof(ins));
	for(i=0;i<m;++i)
	{
		scanf("%d%d",&si,&ei);
		road[si][ei]=true;		//构造DAG
	}
}
bool find(int p)
{
	int i,j;
	for(i=1;i<=n;++i)		//扫描虚拟路口
	{
		if(road[p][i]==true&&!vis[i])
		{
			vis[i]=true;
			if(ins[i]==0||find(ins[i]))
			{
				ins[i]=p;	//给未安排伞兵的 或可调整伞兵的路口 安排伞兵
				return true; 
			}
		}
	}
	return false;
}
int main()
{
	int t,i,count,ans;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		init();
		count=0;
		for(i=1;i<=n;++i)	//扫描路口 
		{
			memset(vis,0,sizeof(vis));
			if(find(i))
				count++;
		}
		ans = n	- count;	//路口数 - 最大匹配数 
		printf("%d\n",ans);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值