HDU 5095 Linearization of the kernel functions in SVM【模拟】

Linearization of the kernel functions in SVM

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 2243    Accepted Submission(s): 602


Problem Description
SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2  <-> p, y^2  <-> q, z^2  <-> r, xy  <-> u, yz  <-> v, zx  <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.

Now your task is to write a program to change f into g.
 

Input
The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.
 

Output
For each input function, print its correspondent linear function with 9 variables in conventional way on one line.
 

Sample Input
  
  
2 0 46 3 4 -5 -22 -8 -32 24 27 2 31 -5 0 0 12 0 0 -49 12
 

Sample Output
  
  
46q+3r+4u-5v-22w-8x-32y+24z+27 2p+31q-5r+12w-49z+12
 

Source

题目链接。




模拟。
将给定的数字转换成方程式。
注意以下情况:
1、如果全为0,只输出0。
2、如果只有常数项,只输出常数项(正数不要输出加号)。
3、系数和常数项同时存在:①如果系数为1或-1,只输出符号(+,-)和变量。 
②首个非零项,为正数时不需要输出加号。 
④系数非零时才输出。 
③常数项非零时才输出(为正数要输出+号)。 


#include <cstdio>
#include <cstring>
const int maxn = 15;
int a[maxn];
char var[maxn]={'o','p','q','r','u','v','w','x','y','z'};
void judge(int b)
{
	if(b>0&&b!=1)
	{
		printf("%d",b);
	}
	else if(b<0)
	{
		printf("-");
		if(b!=-1)
			printf("%d",-b);
		
	}
}
void function()
{
	int i,flag;
	for(i=1;i<=10;++i)			//查找首个非零项 
		if(a[i]!=0) break;
	if(i==11)
	{
		printf("0");
	}
	else if(i==10)
	{
		printf("%d",a[10]);
	}
	else
	{
		judge(a[i]);
		printf("%c",var[i]);
		for(i++;i<10;++i)
		{
			if(a[i]==0) continue;
			if(a[i]>0) printf("+");
			judge(a[i]);
			printf("%c",var[i]);
		}
		if(a[10]>0)
			printf("+%d",a[10]);
		else if(a[10]<0)
			printf("%d",a[10]);
	}
	printf("\n");
}
int main()
{
	int t,i;
	scanf("%d",&t);
	while(t--)
	{
		for(i=1;i<=10;++i)
			scanf("%d",&a[i]);
		function();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值