HDU 5095 Linearization of the kernel functions in SVM

Linearization of the kernel functions in SVM

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 206    Accepted Submission(s): 109


Problem Description
SVM(Support Vector Machine)is an important classification tool, which has a wide range of applications in cluster analysis, community division and so on. SVM The kernel functions used in SVM have many forms. Here we only discuss the function of the form f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j. By introducing new variables p, q, r, u, v, w, the linearization of the function f(x,y,z) is realized by setting the correspondence x^2  <-> p, y^2  <-> q, z^2  <-> r, xy  <->u, yz  <-> v, zx  <-> w and the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j can be written as g(p,q,r,u,v,w,x,y,z) = ap + bq + cr + du + ev + fw + gx + hy + iz + j, which is a linear function with 9 variables.

Now your task is to write a program to change f into g.
 

Input
The input of the first line is an integer T, which is the number of test data (T<120). Then T data follows. For each data, there are 10 integer numbers on one line, which are the coefficients and constant a, b, c, d, e, f, g, h, i, j of the function f(x,y,z) = ax^2 + by^2 + cy^2 + dxy + eyz + fzx + gx + hy + iz + j.
 

Output
For each input function, print its correspondent linear function with 9 variables in conventional way on one line.
 

Sample Input
  
  
2 0 46 3 4 -5 -22 -8 -32 24 27 2 31 -5 0 0 12 0 0 -49 12
 

Sample Output
  
  
46q+3r+4u-5v-22w-8x-32y+24z+27 2p+31q-5r+12w-49z+12
 


 有 -1 和 1 的情况 , 考虑清楚就ok了 。

这是一个细心题,一开始写代码的时候还记得要特别注意1和-1的情况。代码写着写着就忘掉了。
一方面可能是平时组队赛,细心度上对队友产生依赖了
另一方面,太相信自己能在写代码的时候还记得这些注意点。以后应该吧脑海里一闪而过的注意点先写在纸上。
#include<iostream>
#include<cstdio>
using namespace std;
char mp[10]={'p','q','r','u','v','w','x','y','z','A'};
int main()
{
	int t;
	cin >> t;
	while(t--)
	{
		int flag = -1;
		int xx;
		for(int i=0;i<10;i++)
		{
			scanf("%d",&xx);
			if(xx!=0){	
				if(i==9)
				{
					if(flag ==-1)
					printf("%d",xx);
					else
					{
						if(xx>0)
						printf("+%d",xx);
						else
						printf("%d",xx);
					}
				}
				else
				{	
				if(flag == -1)
				{
					if(xx!=1&&xx!=-1)
					printf("%d%c",xx,mp[i]);
					else
					{
						if(xx == 1)
						printf("%c",mp[i]);
						else
						printf("-%c",mp[i]);
					}
				}	
				else
				{
					if(xx>0)
					{
						if(xx!=1)
					printf("+%d%c",xx,mp[i]);
					else
						printf("+%c",mp[i]);
					}				
					else				
					{
						if(xx!=-1)
					printf("%d%c",xx,mp[i]);
					else
					printf("-%c",mp[i]);	
					}				
				}			
		}
		flag = 1;
		}
		
		
	}
	cout<<endl;
}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值