Wormholes

C - Wormholes
Crawling in process... Crawling failed Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

 

这个题的意思就是每一组数据中m是有m组路,双向边,且是正权值,接下来w组路,单向边,且是负权值,如果当你回到原位时发现自己回到了时间之前,也就是说回路是负的,也就是说,只要判断是否有负权回路;

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define oo 1<<28
struct node
{
    int u,v;
    int w;
} edge[1000000];
int dist[10000];
int s,n,m,l;
int u,v,w;
void init(int s)
{
    for(int i=0; i<n; i++)
    {
        dist[i]=oo;
    }
    dist[s]=0;
}
int Bellman_Ford()
{
    for(int i=1; i<=n-1; i++)
    {
        for(int j=1; j<=m*2+l; j++)
        {
            if(dist[edge[j].v]>dist[edge[j].u]+edge[j].w)
            {
                dist[edge[j].v]=dist[edge[j].u]+edge[j].w;
            }
        }
    }
    int flag=1;
    for(int i=1; i<=n-1; i++)
    {
        for(int j=1; j<=m*2+l; j++)
        {
            if(dist[edge[j].v]>dist[edge[j].u]+edge[j].w)
            {
                flag=0;
                break;
            }
        }
    }
    return flag;
}
int main()
{
    int i,a,w;
    scanf("%d",&a);
    while(a--)
    {
        s=1;
        init(s);
        scanf("%d%d%d",&n,&m,&l);
        int a,b,c;
        for(i=1; i<=m; i++)
        {
            //scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
            scanf("%d%d%d",&a,&b,&c);
            edge[(i-1)*2+1].u=a;
            edge[(i-1)*2+1].v=b;
            edge[(i-1)*2+1].w=c;
            edge[i*2].u=b;
            edge[i*2].v=a;
            edge[i*2].w=c;
            if(edge[i].u==s)
                dist[edge[i].v]=edge[i].w;
        }
        for(i=2*m+1; i<=2*m+l;i++)
        {
            scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].w);
            edge[i].w=-edge[i].w;
            if(edge[i].u==s)
                dist[edge[i].v]=edge[i].w;
        }
        if(Bellman_Ford())
            printf("NO\n");
        else
            printf("YES\n");
    }
     return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值