E - Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
这个题套了学长的模板,后来发现过不了
直到。。。Two fields might be connected by more than one path.
以后得仔细读题啊

/*

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

*/
#include<cstdio>
#include<cstring> 
#include<iostream>
#include<queue>
#define INF 0x3f3f3f3f
using namespace std;
int dis[505][505];
int res[505];
int flag[505];
int inq[505];
int n,m,w;//field path hole  500 2500 200
queue<int> q;
bool SPFA(int start)
{
	
	memset(flag,0,sizeof(flag));     //默认不在队列中 
	memset(res,0x3f3f3f3f,sizeof(res));//初始不通 
	memset(inq,0,sizeof(inq));        //进入队列 次数
	q.push(start);
	res[start]=0;
	inq[start]=1;
	flag[start]=1;
	while(!q.empty()){
		int newnode=q.front();
		q.pop();
		flag[newnode]=0;
		for(int i=1;i<=n;i++){
			if(i==newnode) continue;
			if(res[i]>res[newnode]+dis[newnode][i]){
				res[i]=res[newnode]+dis[newnode][i];
				if(flag[i]==0){
					flag[i]=1;
					q.push(i);
					inq[i]++;
//					cout<<"i"<<i<<endl;
					if(inq[i]>n) return false;
				}
			} 
		} 
	}
	return true;//没有负圈 
}

int main()
{
	int t;
	cin>>t;
	while(t--){

		memset(dis,INF,sizeof(dis));
		scanf("%d %d %d",&n,&m,&w);
		for(int i=0;i<m;i++){
			int a,b,c;
			scanf("%d %d %d",&a,&b,&c);
			dis[a][b]=dis[b][a]=min(dis[a][b],c);
		}
		for(int i=0;i<w;i++){
			int a,b,c;
			scanf("%d %d %d",&a,&b,&c);
			dis[a][b]=min(dis[a][b],-c);
		}
		if(SPFA(1)) cout<<"NO"<<endl;
		else cout<<"YES"<<endl;
	} 

	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

洛阳八中我最棒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值