Minimum Inversion Number(线段树单点更新+逆序数)

Minimum Inversion Number(线段树单点更新+逆序数)
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj. 

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following: 

a1, a2, ..., an-1, an (where m = 0 - the initial seqence) 
a2, a3, ..., an, a1 (where m = 1) 
a3, a4, ..., an, a1, a2 (where m = 2) 
... 
an, a1, a2, ..., an-1 (where m = n-1) 

You are asked to write a program to find the minimum inversion number out of the above sequences. 
 

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1. 
 

Output

For each case, output the minimum inversion number on a single line. 
 

Sample Input

     
     
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output

     
     
16
 
1:逆序数:i<j,ai>aj,如:4 5 3 2 1,
4的逆序数个数0
5的逆序数个数0
3的逆序数4 5,个数2
2的你叙述4 5 3,个数3
1的逆序数4 5 3 2,个数4
2:离散化的方法
每加入一个数,该位置对应的sum标记1,并更新。
在该位置之后的到n的范围内的1的个数就是这个数的逆序数。
如加入4,逆序数0
加入5,逆序数0
加入3,位置4,5均有1,逆序数为2
加入2,位置3,4,5均有1,逆序数为3
加入1,位置2 3 4 5,逆序数为4.
3最小逆序数对

先求出第一个序列的逆序数,然后用很巧妙的办法求下一个序列的逆序数,直到全部求出;

       序列 4 5 2 1 3 6 ,此序列的逆序数为7,它等到的下一个序列为 5 2 1 3 6 4

       看这个新序列的产生过程,首部删除4,尾部添加4

       删除4,必然会使得这个序列的逆序数减少(4-1)个,因为4前面必定有4-1个数小于4

       添加4,必然会使得这个序列的逆序数增加(6-4)个,因为4后面必定有6-4个数大于4

       由此推出公式,假设移动的数为m,序列的逆序数=上一序列逆序数-(m-1)+(N-m)


#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;
#define maxn 10001
#define inf 0x3f3f3f3f
int ll[maxn<<2],rr[maxn<<2],sum[maxn<<2];
int a[maxn];
void build(int l,int r,int i){
    ll[i]=l;
    rr[i]=r;
    sum[i]=0;
    if(ll[i]==rr[i]){
        return ;
    }
    int m=(l+r)>>1,ls=i<<1,rs=ls|1;
    build(l,m,ls);
    build(m+1,r,rs);
    sum[i]=sum[ls]+sum[rs];
}
void update(int k,int i){
    if(ll[i]==rr[i]){
        sum[i]=1;
        return;
    }
    int m=(ll[i]+rr[i])>>1,ls=i<<1,rs=ls|1;
    if(k<=m){
        update(k,ls);
    }
    else{
        update(k,rs);
    }
    sum[i]=sum[ls]+sum[rs];
}
int finds(int l,int r,int i){
    if(ll[i]==l&&rr[i]==r){
        return sum[i];
    }
    int m=(ll[i]+rr[i])>>1,ls=i<<1,rs=ls|1;
    if(r<=m){
        return finds(l,r,ls);
    }
    else if(l>m){
        return finds(l,r,rs);
    }
    else{
        return finds(l,m,ls)+finds(m+1,r,rs);
    }

}
int main()
{
    int n;
    int ss;
    //freopen("in.txt","r",stdin);
    while(scanf("%d",&n)!=EOF){
            build(0,n+1,1);
            ss=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            update(a[i],1);
            ss+=finds(a[i]+1,n+1,1);
           // printf("%d ",ss);
        }
      //  printf("\n");
        int mas=ss;
        //printf("%d\n",ss);
        for(int i=1;i<=n;i++){
            ss=ss-a[i]+(n-1-a[i]);
           // printf("%d ",ss);
            if(ss<mas)mas=ss;
        }
        printf("%d\n",mas);

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值