POJ 2551 Ones(取模)

B - Ones
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

Given any integer 0 <= n <= 10000 not divisible by 2 or 5, some multiple of n is a number which in decimal notation is a sequence of 1's. How many digits are in the smallest such a multiple of n?

Input

Each line contains a number n.

Output

Output the number of digits.

Sample Input

3 
7 
9901

Sample Output

3
6
12


111111%n=(1%n+10%n+100%n+1000%n+10000%n)%n

11%n=(10%n+1%n)%n;

111%n=(110%n+1%n)=(10*11%n+1)%n

由此推出公式

int  temp=1;int cnt=1;

while(temp!=0){

     temp=(temp*10+1)%n;

     cnt++;

}

cout<<cnt<<endl;


#include<iostream>
#include<cstdio>
using namespace std;
int main()
{
   int n;
   while(~scanf("%d",&n)){
      int cnt=1;
      int temp=1;
      while(temp!=0){
        temp=(temp*10+1)%n;
        cnt++;
      }
      cout<<cnt<<endl;
  }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值