01背包最简单最经典的入门题

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2  31).
 

Sample Input

       
       
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

       
       
14
 
题目大体意思是有n个东西,背包容量为m,给出每个东西的价值和体积,求背包能装下的最大价值。有点简单,不叨叨,直接给源代码,都能看懂。
#include<stdio.h>
#include<string.h>
int bone[1001];
struct sa
{
    int W,V;
}data[1001];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int t,i,j;
    while(scanf("%d",&t)!=EOF)
    {
    while(t--)
    {
        memset(bone,0,sizeof(bone));
        int n,v;
        scanf("%d%d",&n,&v);
        for(i=1;i<=n;i++)
        scanf("%d",&data[i].W);
        for(j=1;j<=n;j++)
        scanf("%d",&data[j].V);
        for(i=1;i<=n;i++)
        for(j=v;j>=data[i].V;j--)
        {
            bone[j]=max(bone[j],bone[j-data[i].V]+data[i].W);
        }
        printf("%d\n",bone[v]);
    }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值