D-City
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)Total Submission(s): 4015 Accepted Submission(s): 1440
Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
Sample Input
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
Sample Output
1 1 1 2 2 2 2 3 4 5HintThe graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
Source
题意:某人要把城市里的路都破坏掉,提问每次破坏一条路这个图上还有几个群落(群落??专业术语是啥来着。。)
把破坏的过程反着来,假设一条边一条边地加上去
/*
━━━━━┒
┓┏┓┏┓┃μ'sic foever!!
┛┗┛┗┛┃\○/
┓┏┓┏┓┃ /
┛┗┛┗┛┃ノ)
┓┏┓┏┓┃
┛┗┛┗┛┃
┓┏┓┏┓┃
┛┗┛┗┛┃
┓┏┓┏┓┃
┛┗┛┗┛┃
┓┏┓┏┓┃
┃┃┃┃┃┃
┻┻┻┻┻┻
*/
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <map>
#include <stack>
using namespace std;
const int maxn = 1e5+10;
int n,m;
int pre[maxn];
pair<int,int> edge[maxn];
int res[maxn];
int find(int x){
return pre[x]==x?x:pre[x]=find(pre[x]);
}
int join(int a,int b){
int rea,reb;
rea = find(a),reb = find(b);
//cout<<a<<" "<<rea<<" "<<b<<" "<<reb<<endl;
pre[reb]=rea;
if(rea!=reb){
return -1;
}
return 0;
}
int main(){
int i,j,u,v,now;
while(~scanf("%d%d",&n,&m)){
for(i=1;i<=m;i++){
scanf("%d%d",&u,&v);
edge[i] = make_pair(u, v);
}
for(i=0;i<n;i++){
pre[i] = i;
}
now = n;
for(i=m;i>=1;i--){
res[i] = now;
now += join(edge[i].first,edge[i].second);
}
for(i=1;i<=m;i++){
printf("%d\n",res[i]);
}
}
return 0;
}