HDU 4496 D-City 并查集倒排加边

D-City

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 4344 Accepted Submission(s): 1530

Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4

Sample Output
1
1
1
2
2
2
2
3
4
5
Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there’s only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4496

题意

给出点的个数和边,输出去掉前k条边的时候非连通集合有多少个?

题解

这题是很明显的并查集,很重要的一点是去掉前k条边,完全可以倒过来求解,也就是从最后一条边开始慢慢加边。
在计算的时候,开始非连通集合就是点的个数n,之后每一个点并入任一连通集合,非连通集合的个数就-1.
不用倒排加边,基本上是TLE......

#include <bits/stdc++.h>
//#include<stdio.h>
//#include<stdlib.h>
//#include<math.h>
//#include<algorithm>
//#include<string.h>
//#include<string>
//#include<stack>
//#include<queue>
//#define INF 0xffffffff
using namespace std;
typedef long long ll;

const int maxn = 10005;
const int maxm = 100005;

int tol;

struct Edge{
    int u, v;
}edge[maxm];

int n, m;
int f[maxn];
int ans[maxm];

void addedge(int u, int v){
    edge[tol].u = u;
    edge[tol++].v = v;
}

int find(int x){
    return (x == f[x])? f[x] : f[x]=find(f[x]);
}

int main(){
    while(scanf("%d%d", &n, &m) == 2 && n && m){
        tol = 0;
        for(int i=0; i<n; i++){
            f[i] = i;
        }
        for(int i=0; i<m; i++){
            int u, v;
            scanf("%d%d", &u, &v);
            addedge(u, v);
        }
        int cnt = n;
        for(int i=m-1; i>=0; i--){
            ans[i] = cnt;
            int u = edge[i].u;
            int v = edge[i].v;
            int t1 = find(u);
            int t2 = find(v);
            if(t1 != t2){
                f[t1] = t2;
                cnt -- ;
            }
        }
        for(int i=0; i<m; i++){
            printf("%d\n", ans[i]);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值