hdu 1719 Friend 数学推导

题链:http://acm.hdu.edu.cn/showproblem.php?pid=1719

Friend

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2099    Accepted Submission(s): 1058


Problem Description
Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.
 

Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 

Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 

Sample Input
  
  
3 13121 12131
 

Sample Output
  
  
YES! YES! NO!
 



题意:1和2是友好数,如果a,b是友好数,那么a*b+a+b也是友好数。

做法:

friend=a*b+a+b=a*b+a+b+1-1=(a+1)*(b+1)-1

假设a=(c+1)*(d+1)-1 b=(e+1)*(f+1)-1

那么friend=(c+1)*(d+1)*(e+1)*(f+1)-1

然后可以把一个friend数通过这样,不断带入分解,最后肯定是 (c+1)*(d+1)*(e+1)*(f+1)*(g+1)*(h+1)*(i+1)*.....-1这种形式,分解到最后,就是里面字母全是1或者2了。

然后可以得任何一个friend=2^n+3^m-1;

所以某个数加1后,如果质因数只有2和3,那么这个数就是friend数。   


#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <limits.h>
#include <malloc.h>
#include <ctype.h>
#include <math.h>
#include <string>
#include <iostream>
#include <algorithm>
using namespace std;
#include <stack>
#include <queue>
#include <vector>
#include <deque>
#include <set>
#include <map>
#define INF 999999999
#define eps 0.00001
#define LL __int64
#define pi acos(-1.0)
 
int main()
{
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		if(n==0)
		{
			printf("NO!\n");
			continue;
		}
		n++;
		while(n%2==0) n/=2;
		while(n%3==0) n/=3;
		if(n==1)
			printf("YES!\n");
		else
			printf("NO!\n");
	}
	return 0;
}
/*
4 1
2 3 4 1
1 2 3 4

*/


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值