HDU1719:Friend

Problem Description
Friend number are defined recursively as follows.
(1) numbers 1 and 2 are friend number;
(2) if a and b are friend numbers, so is ab+a+b;
(3) only the numbers defined in (1) and (2) are friend number.
Now your task is to judge whether an integer is a friend number.
 

Input
There are several lines in input, each line has a nunnegative integer a, 0<=a<=2^30.
 

Output
For the number a on each line of the input, if a is a friend number, output “YES!”, otherwise output “NO!”.
 

Sample Input
  
  
3 13121 12131
 

Sample Output
  
  
YES! YES! NO!
 


 

这道题就是以道纯数学题,我记得第一次看到这道题还是在刚刚搞ACM不久的时候,当时硬是没有想出解决的方法

直到昨天训练赛的时候又出了这道题,仍然是没有弄出来,果然我的数学思维还是不行啊,在看了别人的题解之后,终于算是看懂意思了,在此有必要解释一下

 

首先,原式ab+a+b = ab+a+b+1-1 = (a+1)*(b+1)-1

令a = (a1+1)*(a2+1)-1;

b = (b1+1)*(b2+1)-1;

代入原式中可得:n = (a1+1)*(b1+1)*(a2+1)*(b2+1)-1;

因为原式的朋友数都是由1,2推到出来的

所以递推到最底层,那么(a1+1)*(b1+1)*(a2+1)*(b2+1)肯定是2,3的倍数(即是1+1,2+1)

所以最后就是要解决n+1得到的数到底是不是只有2,3这些因子

 

#include <stdio.h>

int main()
{
    __int64 n;
    while(~scanf("%I64d",&n))
    {
        if(!n)
        {
            printf("NO!\n");
            continue;
        }
        n++;
        while(n%2==0)
            n/=2;
        while(n%3 == 0)
            n/=3;
        if(n==1)
            printf("YES!\n");
        else
            printf("NO!\n");
    }

    return 0;
}


 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值