HDU 5984 ACM-ICPC Regional QingDao(数学期望)

Pocky

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 580    Accepted Submission(s): 315

Problem Description

Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point.

Input

The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.

Output

For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

Sample Input

 
 
6 1.0 1.0 2.0 1.0 4.0 1.0 8.0 1.0 16.0 1.0 7.00 3.00

Sample Output

 
 
0.000000 1.693147 2.386294 3.079442 3.772589 1.847298

Source

2016ACM/ICPC亚洲区青岛站-重现赛(感谢中国石油大学)



        人生第一道数学期望程序,纪念一下……

        就是跟你一根棍子长度为L,你每次可以在任何一个点把它折断,同时拿走左边那段,对右边那段棍子继续重复刚刚的动作,知道剩下的棍子的长度小于d。然后问你在根除L和d的情况下,期望多少次能够使得不能继续把棍子截断。

        本来好好的一道数学题,被大部分人做成了找规律的玄学题……鄙视(╬▔皿▔)凸找规律的人……

        其实,数学公式也是挺好推的,我们设期望的数列为an,对应an的前n项和胃sn,那么显然有递推式:an=sn-1/(n-1)+1,其中这个n表示有n个单位长度的棍子的期望。于是我用这条式子尝试递推计算,发现结果正确无疑,但是总是在最后几位不能精确。原因就在于我们取得单位长度不够小,而且单位长度我是让他却决于分的块数,由于时间复杂度的限制,块数显然不能太多(递推的时间复杂度是O(N),故块数N不能太大)。接着我尝试增大块数,发现直到块数设为1e9我都不能消除最后一位的误差。于是我考虑放弃这种方法,转而求数列通项。

        很容易求出an的通项公式:an=1/n+1/(n-1)+1/(n-2)+……+1。但是实际上,并不是这个,在长度小于等于d之后对应数列中的项为0,故不是直接调和级数的和。但是我们肯定要先求出调和级数的和。根据欧拉推到出来的式子,Orz……调和级数第n项和等于ln(n)+C,其中的C为欧拉常数,数值约为0.5772156649。通过这个我们可以求出调和级数的和。然后回到刚刚的问题,长度小于等于d之后期望直接为0,这个的话,我们最后直接减去长度为d对应那一项的调和级数的和再加一即可。这样子完整的方法就出来了。最后值得注意的点是,欧拉推倒出来的的调和级数的和要在N大于百万的时候才能用。但是这是我们是直接求通项,O(1)的复杂度就可以算出来,故N的大小可以放心的取。我在这里就取了1e11。具体见代码,再次膜拜欧拉Orz……:

#include<bits/stdc++.h>
#define N 100000000000
#define C 0.5772156649							//欧拉常数
using namespace std;

double l,d,f,s;

double getsum(long long x)						//计算调和级数的和
{
	return log(x)+C;
}

int main()
{
	int T_T;
	cin>>T_T;
	while(T_T--)
	{
		int i; f=s=0;
		scanf("%lf%lf",&l,&d);
		if (l<=d) 
		{
			printf("%.6lf\n",0);
			continue;
		}
		double blocks=l/N;					//计算单位长度
		printf("%.6lf\n",getsum(N)-getsum(d/blocks)+1);		//结果减去长度为d时对应项的和再加上1
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值