Wireless Network

Time Limit:10000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

题意: 有N 台坏了的电脑, 通讯的最长距离是D

         O p 要修的电脑

         S p q  判断两台电脑是否能够通讯,,

思路: ;并查集+ 距离的判断

          这题主要卡在对距离的判断, 开始想到的方法是 修一台电脑,然后判断与前后两台已修好的电脑的距离, 若小于D ,则 复制根节点...这个方法自己运行可以得到答案, 但是总是WA..至今找不到问题所在~ 后来转换思路..其实这样想有点绕, 只要将每次修的电脑与所有的电脑循环一遍, 使用rel数组判断电脑是否修过..再判断距离, 小于等于D则复制根节点~

       

#include<stdio.h>
#include<iostream>
#include<string.h>
#include<math.h>
using namespace std;
int set[1005];
int rel[1005];
int x[1005],y[1005];

void init(int nn)
{
    for(int i=1;i<=nn;i++)
    {
        set[i]=i;
        rel[i]=0;
    }
}
int find(int a)
{
    if(a==set[a])return a;
    else return set[a]=find(set[a]);

}
double cal(int fr,int be)
{
    return sqrt((x[fr]-x[be])*(x[fr]-x[be])+(y[fr]-y[be])*(y[fr]-y[be]));
}

void unite(int cc,int ij)
{
    set[find(cc)]=find(ij);
}
int main()
{
    //freopen("E.txt","r",stdin);
    int N;
    double D;
    scanf("%d%lf",&N,&D);
    init(N);
    for(int i=1;i<=N;i++)
    {
        scanf("%d%d",&x[i],&y[i]);
    }
    getchar();
    char ch;
    int a,b,c;
    while(~scanf("%c",&ch))
    {

        if(ch=='O')
        {
            scanf("%d",&c);
            rel[c]=1;
            for(int i=1;i<=N;i++)
            {
                if(rel[i]&&cal(c,i)<=D)
                    unite(c,i);
            }
            /*
            int i=c-1;
            while(i>=1&&rel[i]==0)
            {
                i--;
            }
            if(i!=0)
            {rel[c]=cal(c,i);  printf("%lf\n",rel[c]);
             unite(c,D,i);}
            int j=c+1;
            while(j<=N&&rel[j]==0)
            {
                j++;
            }
            if(j!=N+1)
            {rel[j]=cal(j,c);  printf("%lf\n",rel[j]);
             unite(j,D,c);}
             */

        }
        if(ch=='S')
        {
            scanf("%d%d",&a,&b);
            if(find(a)!=find(b))printf("FAIL\n");
            else printf("SUCCESS\n");
        }
        getchar();
    }
    return 0;
}

PS: 注释掉的是一开始对距离判断的方法...路过的大神有空的话帮我看一看~谢过了^.^


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值