POJ 2139-Six Degrees of Cowvin Bacon(最短路Floyd)

Description

The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.

Output

* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.

Sample Input

4 2
3 1 2 3
2 3 4

Sample Output

100

                                                         

题意:输入n个点和m行,每一行输入k 和k 个数字,数字之间两两相连,之间的权值为1。求出点到其他个点的总距离×100/(n-1)的最小值。

思路:最短路,Floyd算法。

            注意d[i][j]不存在是设为inf,d[i][i] = 0。

CODE:

#include <iostream>
#include <cstdio>
using namespace std;

const int inf = 0xfffff;
int d[305][305];
int a[305];
int n, m;

void floyd()
{
    for(int k = 1; k <= n; ++k) {
        for(int i = 1; i <= n; ++i) {
            for(int j = 1; j <= n; ++j) {
                d[i][j] = min(d[i][j], d[i][k] + d[k][j]);
            }
        }
    }
}

int main()
{
//freopen("in", "r", stdin);
    while(~scanf("%d %d", &n, &m)) {
        for(int i = 0; i <= n; ++i) {
            for(int j = 0; j <= n; ++j) {
                d[i][j] = inf;
                if(i == j) d[i][j] = 0;
            }
        }

        while(m--) {
            int k;
            scanf("%d", &k);
            for(int i = 0; i < k; ++i) {
                scanf("%d", &a[i]);
                for(int j = 0; j < i; ++j) {
                    d[a[i]][a[j]] = d[a[j]][a[i]] = 1;
                }
            }
        }
        floyd();
//        for(int i = 1; i <= n; ++i) {
//            for(int j = 1; j <= n; ++j) {
//                printf("%d->%d: %d\n", i, j, d[i][j]);
//            }
//        }
        int ans = inf, res;
        for(int i = 1; i <= n; ++i) {
            res = 0;
            for(int j = 1; j <= n; ++j) {
                if(i != j)
                    res += d[i][j];
            }
            ans = min(ans, res);
        }
        printf("%d\n", ans*100/(n - 1));
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值