杭电1248杭电1114————完全背包

寒冰王座

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10762    Accepted Submission(s): 5460


Problem Description
不死族的巫妖王发工资拉,死亡骑士拿到一张N元的钞票(记住,只有一张钞票),为了防止自己在战斗中频繁的死掉,他决定给自己买一些道具,于是他来到了地精商店前.

死亡骑士:"我要买道具!"

地精商人:"我们这里有三种道具,血瓶150块一个,魔法药200块一个,无敌药水350块一个."

死亡骑士:"好的,给我一个血瓶."

说完他掏出那张N元的大钞递给地精商人.

地精商人:"我忘了提醒你了,我们这里没有找客人钱的习惯的,多的钱我们都当小费收了的,嘿嘿."

死亡骑士:"......"

死亡骑士想,与其把钱当小费送个他还不如自己多买一点道具,反正以后都要买的,早点买了放在家里也好,但是要尽量少让他赚小费.

现在死亡骑士希望你能帮他计算一下,最少他要给地精商人多少小费.
 

Input
输入数据的第一行是一个整数T(1<=T<=100),代表测试数据的数量.然后是T行测试数据,每个测试数据只包含一个正整数N(1<=N<=10000),N代表死亡骑士手中钞票的面值.

注意:地精商店只有题中描述的三种道具.
 

Output
对于每组测试数据,请你输出死亡骑士最少要浪费多少钱给地精商人作为小费.
 

Sample Input
  
  
2 900 250
 
    这个题是最最最基本的完全背包了...一张钞票的总金额相当于背包容量 一共三种物品 每一种数量无限 想要消费最少 也就是花出的钱最多..
<span style="font-family:Microsoft YaHei;font-size:14px;">#include <stdio.h>
#include <string.h>
#define max(A,B) ( (A) > (B) ? (A) : (B) )
#define maxn 10005

int main()
{
	int T;
	int totalmoney;
	int  value[3] = {150,200,350};
	int dp[maxn];/*dp[i]表示i元钱可以获得的最大价值*/ 
	
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&totalmoney);
		memset(dp,0,sizeof(dp));
		for(int i = 0 ; i < 3 ; i++)
		{
			for(int j = value[i] ; j <=totalmoney ; j++)
				dp[j] = max(dp[j],dp[j-value[i]] + value[i]);
		}
		printf("%d\n",totalmoney - dp[totalmoney]);
	}
	return 0;
}</span>


  
  

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 11789    Accepted Submission(s): 5947
Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid.  But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams. 
 
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.". 
 
Sample Input
     
     
3 10 110 2 1 1 30 50 10 110 2 1 1 50 30 1 6 2 10 3 20 4
 

Sample Output
     
     
The minimum amount of money in the piggy-bank is 60. The minimum amount of money in the piggy-bank is 100. This is impossible.

这个题目好像稍微绕一下..但其实也是基本的完全背包。
 知道硬币的总重量是totalmoney,每一种硬币的value和weight,求出最少有多少钱。
 感觉把完全背包中的状态转移方程改成min就好了,然而我第一次这样改给了一个WA...
 有点想不明白...
 后来明白了...求最小值的话dp[i]初始化肯定不能为0啊,不然怎么求都是0..然后把dp[i]初始化为MAX = 9999999
 心想这下应该可以了..提交竟然还是WA!...
 为了说的明白一点我把这段代码附上
<span style="font-family:Microsoft YaHei;font-size:14px;">for(i = 0 ; i <= totalweight ; i ++)
	dp[i] = MAX;
for(i = 0 ; i < n ; i++)
	for(j = coin[i].weight ; j <= totalweight ; j++)	
		dp[j] = min(dp[j],dp[j-coin[i].weight]+coin[i].value);</span>
于是我非常纳闷....
然后我就无耻的百度了...................OTZ
然后发现有人这么写
 
<span style="font-family:Microsoft YaHei;font-size:14px;">dp[0] = 0;
for(i = 1 ; i <= totalweight ; i ++)
	dp[i] = MAX;
for(i = 0 ; i < n ; i++)
	for(j = coin[i].weight ; j <= totalweight ; j++)	
		dp[j] = min(dp[j],dp[j-coin[i].weight]+coin[i].value);</span>
然后这就AC了!!
所以我很奇怪...我只好找第一个例子试了试..在纸上写了写,才明白:
如果第一次循环时第一个是dp[0]本身就是MAX,在和一个MAX + value[i]的数取min那肯定还是MAX..以此类推后边都没有发生什么变化...所以说一定要对dp[0]进行修改
<span style="font-family:Microsoft YaHei;font-size:14px;">附AC代码(亲测46MS)
<pre name="code" class="cpp">#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>
#define maxn 505
using namespace std;

const int MAX=9999999;
struct Coin{
	int value;
	int weight;
};
struct Coin  coin[maxn];
int dp[50005];/*dp[i]表示i的总重量下最少有多少元钱*/ 
int main()
{
	int T,E,F;
	int totalweight;
	int n,i,j;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d %d",&E,&F);
		totalweight = F - E;
		scanf("%d",&n);	
		for(i = 0 ; i < n ; i++ )
			scanf("%d %d",&coin[i].value,&coin[i].weight);
		dp[0] = 0;
		for(i = 1 ; i <= totalweight ; i ++)
			dp[i] = MAX;
		for(i = 0 ; i < n ; i++)
			for(j = coin[i].weight ; j <= totalweight ; j++)	
				dp[j] = min(dp[j],dp[j-coin[i].weight]+coin[i].value);
		if(dp[totalweight] == MAX)
	    	printf("This is impossible.\n");
		else
			printf("The minimum amount of money in the piggy-bank is %d.\n",dp[totalweight]);
	}
	return 0;
}
</span>



 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值