HDOJ 5744 Keep On Movin(最大化最短回文串长度)

Professor Zhang has kinds of characters and the quantity of the  i -th character is  ai . Professor Zhang wants to use all the characters build several palindromic strings. He also wants to maximize the length of the shortest palindromic string.

For example, there are 4 kinds of characters denoted as 'a', 'b', 'c', 'd' and the quantity of each character is  {2,3,2,2}  . Professor Zhang can build {"acdbbbdca"}, {"abbba", "cddc"}, {"aca", "bbb", "dcd"}, or {"acdbdca", "bb"}. The first is the optimal solution where the length of the shortest palindromic string is 9.

Note that a string is called palindromic if it can be read the same way in either direction.
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains an integer  n   (1n105)  -- the number of kinds of characters. The second line contains  n  integers  a1,a2,...,an   (0ai104) .
 

Output
For each test case, output an integer denoting the answer.
 

Sample Input
  
  
4 4 1 1 2 4 3 2 2 2 5 1 1 1 1 1 5 1 1 2 2 3
 

Sample Output
  
  
3 6 1 3
 

Author
zimpha

一.总结与分析

做题时候最好先从感性上感觉一下,就会发现,奇数个的个数决定了最后会分成几个集合,然后为了最大化最小值只要先平分那几个偶数的就好了
//
//  main.cpp
//  Keep On Movin
//
//  Created by 张嘉韬 on 16/7/21.
//  Copyright © 2016年 张嘉韬. All rights reserved.
//

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
int c1,c2,L;
int main(int argc, const char * argv[]) {
    //freopen("/Users/zhangjiatao/Documents/暑期训练/input.txt","r",stdin);
    int T=0;
    cin>>T;
    for(int t=1;t<=T;t++)
    {
        int n=0;
        cin>>n;
        L=c1=c2=0;
        for(int i=1;i<=n;i++)
        {
            int temp=0;
            cin>>temp;
            if(temp%2!=0) c2++;
            c1+=temp/2;
            L+=temp;
        }
        if(c2==0) cout<<L<<endl;
        else
        {
            cout<<(c1/c2)*2+1<<endl;
        }
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值