POJ 2492 (树状数组统计数据)

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0
题意:统计一个星星左下方的星星数量(包括在同一条水平线和竖直线上)
很经典的一道用树状数组解决的数据统计的问题,树状数组支持两个功能:1。向a[]表x位置既a[x]加上价值v 2.获得从a[1]到a[x]的的和
那么,就在a[x]位置上加一,sum(x)就可以了,注意本题中x可能为0,所以要加上1
讲解树状数组很好的两篇帖子:点击打开链接
点击打开链接

#include <iostream>
#include <cstring>
#include <cmath>
#include <cstdio>
using namespace std;
const int maxn=32010;
int c[maxn],a[maxn],ans[maxn];

inline int lowbit(int x)
{
    return (x&-x);
}

void add(int x,int value)
{
    for(int i=x;i<=maxn;i+=lowbit(i))
        c[i]+=value;
}

int sum(int x)
{
    int temp=0;
    for(int i=x;i;i-=lowbit(i))
        temp+=c[i];
    return temp;
}
int main()
{
    //freopen("/Users/zhangjiatao/Documents/暑期训练/input.txt","r",stdin);
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(c,0,sizeof(c));
        memset(a,0,sizeof(a));
        memset(ans,0,sizeof(ans));
        for(int t=1;t<=n;t++)
        {
            int x,y,temp;
            scanf("%d%d",&x,&y);
            temp=sum(x+1);
            ans[temp]++;
            add(x+1,1);
        }
        for(int i=0;i<n;i++) cout<<ans[i]<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值