poj 2777 线段树区间更新

http://poj.org/problem?id=2777

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1
题目大意:

                   给定一个区间1~n,给每一个单位区间上一种颜色,进行区间查询,制定区间颜色的中类。

解题思路:

                  由于题目的T是一个很小的数,我们可以把所有颜色添加到一个32位的二进制位里面,每一位对应一种颜色,在进行统计时只需要“|”就可以了,最后将一共有多少个二进制位被标为1,取出来,至于怎么取,请看代码。区间更新和区间统计是线段树的特点不在赘述。

值得一提的地方:1.输入的时候 P  x   y    k    x可能是大于y的。

                                2.初始状态所有的颜色都是颜色1

#include <stdio.h>
#include <string.h>
#include <iostream>
using namespace std;
const int N=100005;
struct SegementTree
{
    struct Tree
    {
        int l,r;
        int sum_color;
        bool flag;
    }tree[N*4];
    void push_up(int root)
    {
        tree[root].sum_color=tree[root<<1].sum_color|tree[root<<1|1].sum_color;
    }
    void push_down(int root)
    {
        if(tree[root].flag)
        {
            tree[root<<1].sum_color=tree[root<<1|1].sum_color=tree[root].sum_color;
            tree[root<<1].flag=tree[root<<1|1].flag=1;
            tree[root].flag=false;
        }
    }
    void build(int root,int L,int R)
    {
        tree[root].l=L;
        tree[root].r=R;
        tree[root].flag=false;
        if(L==R)
        {
            tree[root].sum_color=1;
            return;
        }
        int mid=L+(R-L)/2;
        build(root<<1,L,mid);
        build(root<<1|1,mid+1,R);
        push_up(root);
    }
    void update(int root,int L,int R,int x)
    {
        if(L<=tree[root].l&&tree[root].r<=R)
        {
            tree[root].sum_color=1<<(x-1);//第x位标记为1,即为标记了颜色x
            tree[root].flag=true;
            return;
        }
        push_down(root);
        int mid=tree[root].l+(tree[root].r-tree[root].l)/2;
        if(L<=mid)
            update(root<<1,L,R,x);
        if(mid<R)
            update(root<<1|1,L,R,x);
        push_up(root);
    }
    int  query(int root,int L,int R)
    {
        if(L<=tree[root].l&&tree[root].r<=R)
           return tree[root].sum_color;
        push_down(root);
        int sum=0;
        int mid=tree[root].l+(tree[root].r-tree[root].l)/2;
        if(L<=mid)
            sum|=query(root<<1,L,R);
        if(R>mid)
            sum|=query(root<<1|1,L,R);
        return sum;
    }
    int solve(int sum)//将二进制位表为1的位取出
    {
        int ans=0;
        while(sum)
        {
            if(sum&1)
                ans++;
            sum>>=1;
        }
        return ans;
    }
}tr;
int main()
{
    int n,m,p;
    while(~scanf("%d%d%d",&n,&m,&p))
    {
        tr.build(1,1,n);
        for(int i=0;i<p;i++)
        {
            char c[2];
            int x,y,z;
            scanf("%s",c);
            if(c[0]=='C')
            {
                scanf("%d%d%d",&x,&y,&z);
                if(x>y)
                    swap(x,y);
                tr.update(1,x,y,z);
            }
            else if(c[0]=='P')
            {
                scanf("%d%d",&x,&y);
                if(x>y)
                    swap(x,y);
                int sum=tr.query(1,x,y);
                printf("%d\n",tr.solve(sum));
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值