http://115.28.76.232/problem?pid=1236
Problem Description
Ferry Kingdom is a nice little country located on N islands that are connected by M bridges. All bridges are very beautiful and are loved by everyone in the kingdom. Of course, the system of bridges is designed in such a way that one can get from any island to any other one.
But recently the great sorrow has come to the kingdom. Ferry Kingdom was conquered by the armies of the great warrior Jordan and he has decided to burn all the bridges that connected the islands. This was a very cruel decision, but the wizards of Jordan have advised him no to do so, because after that his own armies would not be able to get from one island to another. So Jordan decided to burn as many bridges as possible so that is was still possible for his armies to get from any island to any other one.
Now the poor people of Ferry Kingdom wonder what bridges will be burned. Of course, they cannot learn that, because the list of bridges to be burned is kept in great secret. However, one old man said that you can help them to find the set of bridges that certainly will not be burned.
So they came to you and asked for help. Can you do that?
Input
The first line of each case contains N and M - the number of islands and bridges in Ferry Kingdom respectively (2 <= N <= 10 000, 1 <= M <= 100 000). Next M lines contain two different integer numbers each and describe bridges. Note that there can be several bridges between a pair of islands.
Output
On the second line print K integers — the numbers of these bridges. Bridges are numbered starting from one, as they are given in the input file.
Sample Input
6 7 1 2 2 3 2 4 5 4 1 3 4 5 3 6
Sample Output
2 3 7
解题思路:对无向图求桥有一套特殊的算法,和有向图求前联通分量相似。
#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
const int N = 10005;
const int M = 100005;
struct node
{
int ok;
int to;
int id;
int next;
} edge[2*M];
int head[N],ip,dfn[N],brg[N],num,cnt,son,n,m;
bool OK(int u, int v)//重边标记,一定不是桥
{
for (int q = head[u]; q!=-1; q = edge[q].next)
if (edge[q].to == v)
{
edge[q].ok = 1;
return true;
}
return false;
}
void addedge(int u, int v, int id)
{
if (OK(u, v))return;
edge[ip].to = v;
edge[ip].ok = 0;
edge[ip].id = id;
edge[ip].next = head[u];
head[u] = ip ++;
}
void init()
{
memset(head,-1,sizeof(head));
memset(dfn,0,sizeof(dfn));
cnt = son = num = 0;
ip=1;
}
int dfs(int u, int fa)//求无向图的桥
{
int low_u;
low_u = dfn[u] = ++ cnt;//标记每个点第一次被访问到的时间戳
for (int i = head[u]; i!=-1; i = edge[i].next)
{
int v = edge[i].to;
if ( !dfn[v])
{
int low_v = dfs(v, u);
low_u = min(low_u, low_v);
if (low_v > dfn[u] && !edge[i].ok)
brg[num ++] = edge[i].id;
}
else if(v != fa)
low_u = min(low_u, dfn[v]);
}
return low_u;
}
int main()
{
while (~ scanf ("%d%d", &n, &m))
{
init();
for (int i = 1; i <= m; i ++)
{
int u,v;
scanf ("%d%d", &u, &v);
addedge(u, v, i);
addedge(v, u, i);
}
dfs(1, 0);
printf ("%d\n", num);
sort(brg, brg + num);//排序输出
for (int i = 0; i < num; i ++)
printf (i == num -1 ?"%d\n":"%d ",brg[i]);
}
return 0;
}