DFS------Lake Counting

http://poj.org/problem?id=2386

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20206 Accepted: 10182

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

bfs模板吧,做了一个小时,我也是无语.加了两个判断,应该是这两个判断弄混淆了.

再写一个判断试试看.第一个是



#include<iostream>
using namespace std;
char a[200][200];
int n, m;
void bfs(int i, int j)
{
	if (a[i][j] == '.')
		return;
	else
	{
		
		a[i][j] = '.';
		bfs(i + 1, j);	
		bfs(i + 1, j + 1);
		bfs(i + 1, j - 1);
		bfs(i , j - 1);
		bfs(i , j + 1);
		bfs(i - 1, j+1);
		bfs(i - 1, j-1);
		bfs(i - 1, j);
	}
}
int main()
{	
	while (cin >> n >> m)
	{
		memset(a, '.', sizeof(a));
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= m; j++)
			{
				cin >> a[i][j];
			}
		}
		int num = 0;
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= m; j++)
			{
				if (a[i][j] == 'W')
				{
					bfs(i, j);
					num++;
				}
			}
		}
			
		cout << num << endl;
	}
}


用vis标记


#include<iostream>
using namespace std;
char a[200][200];
int vis[200][200];
int n, m;
void bfs(int i, int j)
{
	if (a[i][j] == '.'||i<1||i>n||j<1||j>m||vis[i][j]==1)
		return;
	else
	{
		vis[i][j] = 1;
		bfs(i + 1, j);	
		bfs(i + 1, j + 1);
		bfs(i + 1, j - 1);
		bfs(i , j - 1);
		bfs(i , j + 1);
		bfs(i - 1, j+1);
		bfs(i - 1, j-1);
		bfs(i - 1, j);
	}
}
int main()
{	
	while (cin >> n >> m)
	{
		memset(a, '.', sizeof(a));
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= m; j++)
			{
				cin >> a[i][j];
			}
		}
		memset(vis, 0, sizeof(vis));
		int num = 0;
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= m; j++)
			{
				if (a[i][j] == 'W'&&vis[i][j]==0)
				{
					bfs(i, j);
					num++;
				}
			}
		}
			
		cout << num << endl;
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值