图论-DFS-Lake Counting

本文介绍了一种基于深度优先搜索(DFS)的算法,用于计算给定矩形农田地图中形成的水塘数量。该算法通过遍历地图上的每个单元格,如果遇到水域('W'),则启动DFS过程,标记所有相连的水域并将其视为同一水塘的一部分。重复此过程,直到地图上不再有未标记的水域。最终,所启动的DFS次数即为水塘的总数。
摘要由CSDN通过智能技术生成

描述
Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (’.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. Given a diagram of Farmer John’s field, determine how many ponds he has.
输入

Line 1: Two space-separated integers: N and M
Lines 2…N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.

输出
Line 1: The number of ponds in Farmer John’s field.

样例输入

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

样例输出

3

解题思路:
从图中找一个w开始深搜,找其邻接的八个节点中是否存在w点,若存在w点,再进行DFS深搜,直到图中没有w点为止,记录一下重新开始了几遍深搜,就得到水塘的个数。水塘(w连成一片)。
在这里插入图片描述在这里插入图片描述

Code:

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
int N,M,sum=0;
vector<vector<char>>G; 
void DFS(int r,int c){//行 列 
	G[r][c]='.';
	for(int i=-1;i<=1;i++){
		for(int j=-1;j<=1;j++)//八个方向移动 查找是否存在W点 
			if((r+i>=0&&r+i<N)&&(c+j>=0&&c+j<M))//判断是否为水坑 还要保证不越界 
				if(G[r+i][c+j]=='W')//找到W由这个点进行深搜 
					DFS(r+i,c+j);
	}
}
int main(){
	cin>>N>>M;
	G.resize(N);
	for(int i=0;i<N;i++)
		G[i].resize(M);
	char ch;
	for(int i=0;i<N;i++)
		for(int j=0;j<M;j++)
			cin>>G[i][j];//存图 	
	for(int i=0;i<N;i++)
		for(int j=0;j<M;j++){
			if(G[i][j]=='W'){//查找图中是否还存在W点----是否还存在水塘 
				sum++;//若存在水塘数加1 
				DFS(i,j);//从这个W点开始深搜 
			}
		}
	cout<<sum;		
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值