hdu Wooden Sticks

Wooden Sticks	
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 55 Accepted Submission(s) : 17
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3
代码:
#include <iostream>
//#include <algorithm>
#include <cstdio>
using namespace std;
struct student{
	int length;
	int weight;
};
int cmp(const void *c,const void *d)
{
     student *a=(student*)c;
	 student *b=(student*)d;
	if(a->length!=b->length)
		return a->length-b->length;//从小到大排序
	else
		return a->weight-b->weight;
}
/*bool cmp(student b,student c)
{
	if(b.length==c.length)
	return b.weight<c.weight;
	return b.length<c.length;
}*/
int main()
{
	int n,m,i1,i2;
	student s[5005];//注意数比较大,数组应开大些,最初只开了1万多长度,结果wa了好几次,郁闷。
	int st[5005];
	cin>>n;
	for(int i=0;i<n;i++)
	{
		cin>>m;
		for(int j=0;j<m;j++)
		{
			cin>>s[j].length>>s[j].weight;
		}
		qsort(s,m,sizeof(s[0]),cmp);//对结构体数组按长度进行升序排序,若相等按重量升序排列
		memset(st,0,sizeof(st));
		int sum=0,k;
			for(int j1=0;j1<m;j1++)//对排好序的数组一轮一轮的查询
			{
				if(!st[j1])//当前查询的第一个没有被标记过就进行
				{
					k=0;
					st[j1]=1;//标记为一
					int q=j1;//记下该轮的第一个数的下标

				for(i1=j1+1;i1<m;i1++)//依次查找
				{
				if(s[q].weight<=s[i1].weight&&st[i1]!=1)
				{
					st[i1]=1;//满足条件的都做上标记
					q=i1;
				}
				}
				for(int p=0;p<m;p++)//检查有几个数被标记了
					if(st[p]==1)
					k++;
				
				sum++;//记录共有几组
	            if(k==m)//如果所有的数都被标记了,则结束循环
				break;
				}
			}
			cout<<sum<<endl;
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值