Wooden Sticks (HDU 1051)

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12958    Accepted Submission(s): 5336


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 

Source
 
题意:
有n根筷子要加工,每根筷子都知道它长度和重量,加工第一根筷子要1分钟, 后面如果要加工长度和重量大于等于前面那根筷子的长度和重量就不需要时间, 否则需要1分钟. 现给你n跟筷子的长度和重量,问你该如何选择加工筷子的顺序使得花费时间最短.

分析:
要使花费时间最短,就应该使加工筷子的顺序中有更多的后面的筷子长度和重量大于等于前面的长度和重量的片段, 所以可以先按照长度由小到大排序,然后再按顺序找出重量也比前面一个大的筷子,看最多有多少个连续的片段, n-连续片段的数量就是answer. 复杂度为O(n*n).

code:
/*************************************************************************
    > File Name: greedy.cpp
    > Author: tj
    > Mail: 545061367@qq.com
    > Created Time: 2015年01月05日 星期一 11时26分40秒
 ************************************************************************/

#include<stdio.h>
#include<string.h>
#include<algorithm>
#include<iostream>
using namespace std;
struct Compare
{
	int length, weight;
}p[5010];

bool cmp(Compare c, Compare d)
{
	if(c.length != d.length) return c.length < d.length;
	return c.weight < d.weight;
}

int main()
{
	int T, n, vis[5010];

	scanf("%d", &T);
	while(T--)
	{
		memset(vis, 0, sizeof(vis));
		scanf("%d", &n);
		for(int i=1; i<=n; i++)
			scanf("%d%d", &p[i].length,&p[i].weight);
		sort(p+1,p+n+1,cmp);
		int x, y, count = 0, ans = 0, flag = 0;
		for(int i=1; i<=n; i++)
		{
			if(i == n) {printf("%d\n", n-ans); break;}
			if(vis[i]) continue;
			else vis[i] = 1, count++;
			x = p[i].length; y = p[i].weight;
			for(int j=i+1; j<=n; j++)
			{
				if(count == n)
				{
					printf("%d\n", n-ans);
					flag = 1; break;
				}
				if(vis[j]) continue;
				if(p[j].length >= x && p[j].weight >= y)
					vis[j] = 1, count++, ans++, x = p[j].length, y = p[j].weight;
			}
			if(flag) break;
		}
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值