HDU 4324 Triangle LOVE

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=4324

Triangle LOVE

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2616    Accepted Submission(s): 1057


Problem Description
Recently, scientists find that there is love between any of two people. For example, between A and B, if A don’t love B, then B must love A, vice versa. And there is no possibility that two people love each other, what a crazy world!
Now, scientists want to know whether or not there is a “Triangle Love” among N people. “Triangle Love” means that among any three people (A,B and C) , A loves B, B loves C and C loves A.
  Your problem is writing a program to read the relationship among N people firstly, and return whether or not there is a “Triangle Love”.
 

Input
The first line contains a single integer t (1 <= t <= 15), the number of test cases.
For each case, the first line contains one integer N (0 < N <= 2000).
In the next N lines contain the adjacency matrix A of the relationship (without spaces). A i,j = 1 means i-th people loves j-th people, otherwise A i,j = 0.
It is guaranteed that the given relationship is a tournament, that is, A i,i= 0, A i,j ≠ A j,i(1<=i, j<=n,i≠j).
 

Output
For each case, output the case number as shown and then print “Yes”, if there is a “Triangle Love” among these N people, otherwise print “No”.
Take the sample output for more details.
 

Sample Input
  
  
2 5 00100 10000 01001 11101 11000 5 01111 00000 01000 01100 01110
 

Sample Output
  
  
Case #1: Yes Case #2: No
 

Author
BJTU
 

Source

这题HDU1811比起来还嫩了点,但是数据好强,用%1d输入都会TLE,只能用%s或者%c输入才不会超时,C++的输入就更不要用了。

不会这也有可能是我算法的问题,此题用dfs更快,而我用拓扑排序水过~。

思路就不提了跟,跟HDU3342一个模子里刻出来的。 

本来是道水题,就因为数据量大,却废了我好大的劲。水题也有水题的价值所在啊。

下面是AC代码。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<sstream>
#include<vector>
#include<map>
#include<list>
#include<set>
#include<queue>
using namespace std;
const int maxn=2005,maxe=2000005,inf=1<<29;
struct node//前向星(静态链表)
{
    int to,next,w;
}edge[maxe];
char str[maxn];
int n,m,Count;
int head[maxn],cnt;
int in[maxn],id[maxn],iq;//拓扑排序部分数据定义
void add(int from,int to)
{
    edge[cnt].to=to;
    edge[cnt].next=head[from];
    head[from]=cnt++;
}
void topology()
{
    queue<int>q;
    for(int i=0;i<n;i++)
        if(!in[i]) q.push(i);
    while(!q.empty())
    {
        int t=q.front();q.pop();
        Count++;
        for(int j=head[t];j!=-1;j=edge[j].next)
        {
            in[edge[j].to]--;
            if(in[edge[j].to]==0) q.push(edge[j].to);
        }
    }
}
void init()
{
    Count=0;cnt=0;
    memset(in,0,sizeof(in));
    memset(head,-1,sizeof(head));
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int T=1;T<=t;T++)
    {
        scanf("%d",&n);
        init();
        for(int i=0;i<n;i++)
        {
            scanf("%s",str);
            for(int j=0;j<n;j++)
            {
                if(str[j]=='1') add(i,j),in[j]++;
            }
        }
        topology();
        //printf("%d\n",Count);
        if(Count<n) printf("Case #%d: Yes\n",T);
        else printf("Case #%d: No\n",T);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值