HDU 1518 Square

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1518

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8954    Accepted Submission(s): 2912


Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
 

Source
题目大意:给你一些棍子,叫你判断能不能将所有棍子拼成一个正方形。

带回溯的深搜,暴力枚举。适当剪枝即可。难度中下。

下面是AC代码。

#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int sum,n,a[30],m,cnt;
bool flag,vis[30];
void dfs(int d,int s)
{
    if(cnt==4) {flag=true;return ;}
    if(!flag)
    {
        for(int i=d;i<m;i++)
            if(!vis[i]&&!flag)
            {
                if(s+a[i]==sum)
                {
                    vis[i]=1;
                    cnt++;
                    dfs(0,0);
                    cnt--;
                    vis[i]=0;
                }
                else if(s+a[i]<sum)
                {
                    vis[i]=1;
                    dfs(i+1,s+a[i]);
                    vis[i]=0;
                }
            }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        sum=cnt=0;
        memset(vis,0,sizeof(vis));
        scanf("%d",&m);
        for(int i=0;i<m;i++) scanf("%d",&a[i]),sum+=a[i];
        sort(a,a+m);
        if(sum%4 || m<4 || a[m-1]>sum/4) {printf("no\n");continue;}
        flag=0;
        sum/=4;
        dfs(0,0);
        if(flag) printf("yes\n");
        else printf("no\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值