hdu1518 Square



Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
  
  
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
  
  
yes no yes
问给出的这些木棍是否可以正好构成一个正方形。
主要还是考剪枝问题
剪枝一:只要找到了,以后所有的dfs全部return
剪枝二:dfs设计一个变量代表当前已经走到哪里了,深层遍历时直接从那之后开始遍历。这样节省时间!!主要是这个

Problem Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
     
     
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
     
     
yes no yes



#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=20+10;
int a[maxn],vis[maxn];
int edge,average;
int t,sum,flag;
int m;
void dfs(int pos,int w,int count)
{
    if(pos==average)
    {
        count++;
        pos=0;
        w=1;
        if(count==4)
        {
            flag=1;
            return;
        }
    }
    if(flag)
        return;
    for(int i=w;i<=m;i++)
    {
       if(vis[i])
         continue;
       else
       {
           if(pos+a[i]<=average)
           {
               vis[i]=1;
               dfs(pos+a[i],i+1,count);
               vis[i]=0;
           }
       }
    }


}


int main()
{
    scanf("%d",&t);
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        flag=0;
        sum=0;
        scanf("%d",&m);
        for(int j=1;j<=m;j++)
        {
            scanf("%d",&a[j]);
            sum=sum+a[j];
        }
        average=sum/4;
        flag=0;
        if(sum%4!=0||m<4||a[m]>sum/4)
            printf("no\n");
        else
        {
            dfs(0,1,0);
            if(flag)
                printf("yes\n");
            else
                printf("no\n");
        }
    }
    return 0;
}




Problem Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 

Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 

Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
   
   
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
   
   
yes no yes
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值