POJ 3617 Best Cow Line

2 篇文章 0 订阅

题目链接:http://poj.org/problem?id=3617

Best Cow Line
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10673 Accepted: 3204

Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output

ABCBCD
题意:
给定长度为N的字符串S,要构造一个长度为N的字符串T。起初,T是一个空字符串,随后反复进行下列操作。
从S的头部删除一个字符,加到T的尾部
从S的尾部删除一个字符,加到T的尾部
目标是构造字典序小的字符串T。
输出字符一行中有80个字符是,则新起一行。
算法:
按照字典序比较原串S和反转串S'。
如果S较小,就从S的开头取出一个文字追加到T的末尾。
如果S'较小,就从S的尾部取出一个文字追加到T的末尾。
其实字典序比较的问题经常能用得上贪心。
AC代码:
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<sstream>
#include<vector>
#include<map>
#include<list>
#include<set>
#include<queue>
#define LL long long
using namespace std;
const int maxn=1005,maxe=100005,inf=1<<29;
int n,m;
char str[maxe];
int main()
{
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++) scanf("%s",str+i);
       // printf("%s\n",str);
        int l=0,r=n-1,cnt=0;
        while(l<=r)
        {
            bool flag=0;cnt++;
            for(int i=0;l+i<=r;i++)
                if(str[l+i]<str[r-i]) {flag=1;break;}
                else if(str[l+i]>str[r-i]) break;
            if(flag) printf("%c",str[l++]);
            else printf("%c",str[r--]);
            if(cnt%80==0) printf("\n");
        }
        if(cnt%80)
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值