HDU 2795 Billboard

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2795

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11809    Accepted Submission(s): 5195


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
 

题目大意:有一个h*w的广告牌,现在给你n个1*x的海报叫你贴到广告牌上去,尽量往上面靠左贴。

如果贴的上去,就输出贴上去所在的行号,否则输出-1


算法:建立线段树模型。每行对应线段树的一个叶子节点。线段树维护每个区间最大值,这个最大值是指对应区间里广告牌每行剩余空间的最大值。线段树每个区间初始化为w。然后查询的时候紧接着更新。

例如线段数[1,n]维护的是整个区间的最大值,也就是所有行的剩余空间的最大值,其最大值用Max数组存贮,[1,n]的最大值存在下标为1,即Max[1]中,如果每次欲插入的数值x小于Max[1]的话,那么也就是说海报肯定不能贴在广告墙上了。


#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<sstream>
#include<vector>
#include<map>
#include<list>
#include<set>
#include<queue>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
using namespace std;
const int maxn=200005;
int Max[maxn<<2],w,h,n;
void PushUp(int rt)
{
    Max[rt]=max(Max[rt<<1],Max[rt<<1|1]);
}
void build(int l,int r,int rt)
{
    Max[rt]=w;
    if(l==r) return ;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}
int query(int x,int l,int r,int rt)
{
    if(l==r)
    {
        Max[rt]-=x;
        return l;
    }
    int m=(l+r)>>1;
    int ans=(Max[rt<<1]>=x?query(x,lson):query(x,rson));
    PushUp(rt);
    return ans;
}
int main()
{
    while(~scanf("%d%d%d",&h,&w,&n))
    {
        if(h>n) h=n;
        build(1,h,1);
        for(int i=0;i<n;i++)
        {
            int x;
            scanf("%d",&x);
            if(Max[1]<x) puts("-1");
            else printf("%d\n",query(x,1,h,1));
        }
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值