POJ 1459 Power Network

题目链接:http://poj.org/problem?id=1459

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 23572 Accepted: 12344

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6
首先,题意不解释

其次,这道题只是裸网络流稍微改动一下

增加个超级源点和超级汇点。

dinic算法版

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<sstream>
#include<vector>
#include<map>
#include<stack>
#include<list>
#include<set>
#include<queue>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
using namespace std;
const int maxn=1005,maxe=100005,inf=1<<29;
int n,m;
int level[maxn];
struct node
{
    int to,next,f;
}edge[maxe];
int head[maxn],cnt;
void add(int from,int to,int f1,int f2)
{
    edge[cnt].to=to;
    edge[cnt].f=f1;
    edge[cnt].next=head[from];
    head[from]=cnt++;

    edge[cnt].to=from;
    edge[cnt].f=f2;
    edge[cnt].next=head[to];
    head[to]=cnt++;
}
bool makelevel(int s,int t)
{
    memset(level,0,sizeof(level));
    level[s]=1;
    queue<int>q;
    q.push(s);
    while(!q.empty())
    {
        int top=q.front();q.pop();
        if(top==t) return 1;
        for(int i=head[top];i!=-1;i=edge[i].next)
            if(!level[edge[i].to]&&edge[i].f) q.push(edge[i].to),level[edge[i].to]=level[top]+1;
    }
    return 0;
}
int dfs(int now,int Maxf,int t)
{
    int ans=0;
    if(now==t) return Maxf;
    for(int i=head[now];i!=-1;i=edge[i].next)
        if(edge[i].f&&level[edge[i].to]==level[now]+1)
        {
            int f=dfs(edge[i].to,min(Maxf-ans,edge[i].f),t);
            edge[i].f-=f;
            edge[i^1].f+=f;
            ans+=f;
            if(ans==Maxf) return ans;
        }
    return ans;
}
int dinic(int s,int t)
{
    int ans=0;
    while(makelevel(s,t)) ans+=dfs(s,inf,t);
    return ans;
}
int main()
{
     int np,nc,v,c;
       while(~scanf("%d%d%d%d",&n,&np,&nc,&m))
       {
           cnt=0;
        memset(head,-1,sizeof(head));
            for(int i=0;i<m;i++)
            {
                int x,y;
                scanf(" (%d,%d)%d",&x,&y,&c);
                add(x+1,y+1,c,0);
            }
            for(int i=0;i<np;i++)
            {
                scanf(" (%d)%d",&v,&c);
                add(0,v+1,c,0);
            }
            for(int i=0;i<nc;i++)
            {
                scanf(" (%d)%d",&v,&c);
                add(v+1,n+1,c,0);
            }
             printf("%d\n",dinic(0,n+1));
       }
    return 0;
}

EK算法版


#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<sstream>
#include<vector>
#include<map>
#include<stack>
#include<list>
#include<set>
#include<queue>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
using namespace std;
const int maxn=505,maxe=10005,inf=1<<29;
int n,m;
int Map[maxn][maxn],p[maxn];
bool EK_BFS(int s,int e)
{
    queue<int>q;
    bool vis[maxn];
    memset(vis,0,sizeof(vis));
    memset(p,-1,sizeof(p));
    q.push(s);
    vis[s]=1;
    while(!q.empty())
    {
        int t=q.front();q.pop();
        if(t==e) return 1;
        for(int i=0;i<=n+1;i++)
            if(Map[t][i]&&!vis[i]) vis[i]=1,p[i]=t,q.push(i);
    }
    return 0;
}
int EK_Max_Flow(int s,int e)
{
    int ans=0,u,temp;
    while(EK_BFS(s,e))
    {
        temp=inf;
        u=e;
        while(p[u]!=-1) temp=min(temp,Map[p[u]][u]),u=p[u];
        ans+=temp;
        u=e;
        while(p[u]!=-1) Map[p[u]][u]-=temp,Map[u][p[u]]+=temp,u=p[u];
    }
    return ans;
}
int main()
{
        int np,nc,v,c;
       while(~scanf("%d%d%d%d",&n,&np,&nc,&m))
       {
            memset(Map,0,sizeof(Map));
            for(int i=0;i<m;i++)
            {
                int x,y;
                scanf(" (%d,%d)%d",&x,&y,&c);
                Map[x+1][y+1]+=c;
            }
            for(int i=0;i<np;i++)
            {
                scanf(" (%d)%d",&v,&c);
                Map[0][v+1]+=c;
            }
            for(int i=0;i<nc;i++)
            {
                scanf(" (%d)%d",&v,&c);
                Map[v+1][n+1]+=c;
            }
           // for(int i=0;i<=n+1;i++)
              //  for(int j=0;j<=n+1;j++)
                //printf("Map[%d][%d]=%d\n",i,j,Map[i][j]);
            printf("%d\n",EK_Max_Flow(0,n+1));
       }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值