HDU 1016 Prime Ring Problem

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=1016

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31223    Accepted Submission(s): 13818


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
素数环问题,就是求所有满足条件的环,每个环由1~n这n个数填充,相邻的两个数相加之和必须是素数。

首先将素数打好表。

带回溯的深搜。其实这个深搜的过程和枚举全排列过程很相似,所以呢,大家一定要将枚举全排列的思想理解透彻。这样就能解决这一类的问题了。

下面是AC代码:

#include<iostream>
using namespace std;
const int maxn=105;
int n,ans[maxn];
bool vis[maxn],p[maxn];
void init()
{
    fill(p,p+maxn,1);
    p[0]=p[1]=0;
    for(int i=2;i<maxn;i++)
        if(p[i])
        {
            for(int j=2*i;j<maxn;j+=i) p[j]=0;
        }
}
void dfs(int d)
{
    if(d==n)
    {
        if(!p[ans[n-1]+1]) return ;
        for(int i=0;i<n-1;i++) cout<<ans[i]<<" ";
        cout<<ans[n-1]<<endl;
        return ;
    }
    for(int i=2;i<=n;i++)
    {
        if(!vis[i]&&p[ans[d-1]+i])
        {
            ans[d]=i;
            vis[i]=1;
            dfs(d+1);
            vis[i]=0;
        }
    }
}
int main()
{
    init();
    int Case=1;
    bool flag=0;
    while(cin>>n)
    {
        cout<<"Case "<<Case++<<":"<<endl;
        fill(vis,vis+maxn,0);
        ans[0]=1;
        dfs(1);
        cout<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值