hdu 2056 Rectangles

3 篇文章 0 订阅
3 篇文章 0 订阅

Rectangles
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21881 Accepted Submission(s): 7131

Problem Description
Given two rectangles and the coordinates of two points on the diagonals of each rectangle,you have to calculate the area of the intersected part of two rectangles. its sides are parallel to OX and OY .

Input
Input The first line of input is 8 positive numbers which indicate the coordinates of four points that must be on each diagonal.The 8 numbers are x1,y1,x2,y2,x3,y3,x4,y4.That means the two points on the first rectangle are(x1,y1),(x2,y2);the other two points on the second rectangle are (x3,y3),(x4,y4).

Output
Output For each case output the area of their intersected part in a single line.accurate up to 2 decimal places.

Sample Input
1.00 1.00 3.00 3.00 2.00 2.00 4.00 4.00
5.00 5.00 13.00 13.00 4.00 4.00 12.50 12.50

Sample Output
1.00
56.25

题意:给两对点,确定两个矩形,求矩形相交的面积

#include<stdio.h>
#include<stdlib.h>
double temp,temp2;
struct node
{
    double x;
    double y;
    int f;
};
struct node aa[4];
int cmp1(const void *a,const void *b) 
{ 
     struct node *a1=(node *)a; 
     struct node *b1=(node *)b; 
     return(((a1->x)>(b1->x))?1:-1); 
}
int cmp2(const void *a,const void *b) 
{ 
     struct node *a1=(node *)a; 
     struct node *b1=(node *)b; 
     return(((a1->y)>(b1->y))?1:-1); 
}
int main()
{
        aa[0].f=0;
        aa[1].f=0;
        aa[2].f=1;
        aa[3].f=1;
    while(scanf("%lf%lf%lf%lf%lf%lf%lf%lf",&aa[0].x,&aa[0].y,&aa[1].x,&aa[1].y,&aa[2].x,&aa[2].y,&aa[3].x,&aa[3].y)!=EOF)
    {
        aa[0].f=0;
        aa[1].f=0;
        aa[2].f=1;
        aa[3].f=1;
        qsort(aa,4,sizeof(aa[0]),cmp1);
        if(aa[0].f+aa[1].f!=1)
        {
            printf("%.2lf\n",0); 
        }
        else
        {
            temp=aa[1].x-aa[2].x;
        qsort(aa,4,sizeof(aa[0]),cmp2);     
            if(aa[0].f+aa[1].f!=1)
            {
                    printf("%.2lf\n",0); 
            }
            else
            {
                temp2=aa[1].y-aa[2].y;
                    printf("%.2lf\n",temp*temp2); 
            }
        }
    }
    return 0;
}

思路:用结构体定义的点,f 代表 是在第几个矩形的点, 只有F 镶嵌分布才相交,先判断投影在X轴是否相交,再判断投影在Y轴是否相交,只有两个都相交面积才不为零。

坑点,因为之前用的是C++ sort函数,貌似带 函数名没有错,
这里C 语言的qsort 要带 sizeeof (函数名+【0】)。
注意qsort用法

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值