杭电1524 A Chess Game(博弈--- 图)

A Chess Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1370    Accepted Submission(s): 627


Problem Description
Let's design a new chess game. There are N positions to hold M chesses in this game. Multiple chesses can be located in the same position. The positions are constituted as a topological graph, i.e. there are directed edges connecting some positions, and no cycle exists. Two players you and I move chesses alternately. In each turn the player should move only one chess from the current position to one of its out-positions along an edge. The game does not end, until one of the players cannot move chess any more. If you cannot move any chess in your turn, you lose. Otherwise, if the misfortune falls on me... I will disturb the chesses and play it again.

Do you want to challenge me? Just write your program to show your qualification!
 

Input
Input contains multiple test cases. Each test case starts with a number N (1 <= N <= 1000) in one line. Then the following N lines describe the out-positions of each position. Each line starts with an integer Xi that is the number of out-positions for the position i. Then Xi integers following specify the out-positions. Positions are indexed from 0 to N-1. Then multiple queries follow. Each query occupies only one line. The line starts with a number M (1 <= M <= 10), and then come M integers, which are the initial positions of chesses. A line with number 0 ends the test case.
 

Output
There is one line for each query, which contains a string "WIN" or "LOSE". "WIN" means that the player taking the first turn can win the game according to a clever strategy; otherwise "LOSE" should be printed.
 

Sample Input
  
  
4 2 1 2 0 1 3 0 1 0 2 0 2 0 4 1 1 1 2 0 0 2 0 1 2 1 1 3 0 1 3 0
 

Sample Output
  
  
WIN WIN WIN LOSE WIN
/*
把vis[]标记变量定义成了全局变量 ,还好测试数据过不了,要不又得郁闷老半天找不着错
第二道博弈题
Time:2014-8-25 10:38
*/
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int MAX=1000+10;
int sg[MAX];
struct Edge{
	int to;
	int next;
}edge[MAX*5];
int edgeNum,head[MAX];
void Add(int u,int v){
	edge[edgeNum].to=v;
	edge[edgeNum].next=head[u];
	head[u]=edgeNum++;
}
int SG_DFS(int x){
	if(sg[x]!=-1)
		return sg[x];
	bool vis[MAX];
	//注意 不能用全局变量 在递归中,这一层与上一层的无关 
	memset(vis,0,sizeof(vis));
		int u;
	for(int i=head[x];~i;i=edge[i].next){
		u=edge[i].to;
		SG_DFS(u);
		vis[sg[u]]=1;	
	}
	for(int i=0;;i++){
		if(!vis[i]){
			sg[x]=i;
			break;
		}
	}
	return sg[x];
}
void solve(){
	int N;
	while(scanf("%d",&N)!=EOF){
		int X,u;
		edgeNum=0;
		memset(head,-1,sizeof(head));
		for(int i=0;i<N;i++){
			scanf("%d",&X);
			while(X--){// X个整数 表示 i 的出度 
				scanf("%d",&u);
				Add(i,u);
			}
		}
		int Q;
		memset(sg,-1,sizeof(sg));
		while(scanf("%d",&Q),Q){
			int pos,ans=0;
			for(int i=0;i<Q;i++){
				scanf("%d",&pos);
				ans^=SG_DFS(pos);
			}
			if(ans==0)
				printf("LOSE\n");
			else
				printf("WIN\n");
		}
	}
}
int main(){
	solve();
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值